SOLVED

Windows 11's Windows Security App can't open.

Occasional Contributor

Alright guys, just now I'm trying to disable the Windows defender but I found out that I can't even open the Windows Security App. Anyone knows what's going on? Any solution? I'm looking for help. :smile:

163 Replies
best response confirmed by timreck690 (Microsoft)
Solution

@JianYu 


Hello,

Suggest try the following steps:

  • Open PowerShell by using Administrator rights
  • Copy and paste Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage to the PowerShell window and press enter
  • Close the PowerShell and retry
Thanks for your help it works now :)
I tried this and it keeps telling access denied
Hello,
Please make sure you're open PowerShell with local admin rights.

@Little_Joe you're going to have to use the powershell.exe as an Administrator from C:\Windows\System32\WindowsPowerShell\v1.0 to get it to work at this point.

This fix worked for me as well. Thanks! 

@JianYu this solution doesn't work for me

tried other solutions like Windows Security in Windows 11 not opening or working (thewindowsclub.com)

 

except for only reinstallation on my side. Do you have any other solution? I bit doubtful windows defender then install 3rd party  internet security ie, Kaspersky

 

@karthikshaindia If this solution do not work for you, I think you can just follow the reinstall step based on the link you shared or maybe you can install 3rd party antivirus software like you said if you own a license key to activate the software :smiling_face_with_smiling_eyes:

Ran "Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage" in Windows PowerShell as Administrator and it worked!

 

Thank you!

@WinJeffrey 

Glad to know this. :smile:

really thanks, it worked

@Little_Joe Thanks very much.  I was pulling my hair out wondering why some apps were considered threats and not able to open the security app to allow them.

All good now!!!

 

 

Me too :(  ,I've searched but all the results not able to fix !  

 

Access is denied.At line:1 char:1+ Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~+ CategoryInfo : NotSpecified: (:) [Get-AppxPackage], UnauthorizedAccessException+ FullyQualifiedErrorId : System.UnauthorizedAccessException,Microsoft.Windows.Appx.PackageManager.Commands.GetAppxPackageCommand@wrsjj77 

Worked great thanks!
You're welcome! :)
Thanks @Little_Joe. Super helpful!

@Little_Joe 

This worked like a charm, thanks for posting the information.