Unable to update past 19587.1000

Copper Contributor

Good day,

I am a member of Insider Preview (fast). The current OS build is 19587.1000 which was installed on 2020-03-18. My watermark adds: prerelease.200313-1639.


Windows Update typically updates Win10pro64 two or three times per month. There have however been no updates applied to my machine since 19587 (installed on 2020-03-18), and yet there have been a number of new releases.


I also remark that my machine wants to "update and restart" all the time, even immediately after a boot. I strongly suspect that an update is available but it is not being applied.


The machine is otherwise working fine... except that some NetUse are not working. I have worked-around by using IP-addresses instead of Names, and I have read that this was a problem with 19587.


I'd like to update! How can I get un-stuck?


(Please see attached screenshot)





Update on Thursday evening 25 Jun 2020:

Windows Update offered an update to my Nvidia drivers ( They downloaded and apparently were installed correctly. So too was a security update.

And yet, Win10 stubbornly remains at 19587.1000 as it has for months now.

Can anyone suggest a way to get Windows Update to move the OS forward?


6 Replies


Hi there, you are welcome to the Microsoft Tech Community!

The thing is that you need to restart in order to apply the update, you cannot shut down and start the system in order to apply the update. I don't know whether it is a bug or not but I think that it is a safety feature for those who might shut down and start their system later for some work but cannot use their system immediately because the system is updating. In fact, from some recent builds, I can see that there are more options in the start menu and the alt+f4 dialog box when trying to shut down or restart which would mean good for the users who just want to restart but do not want to update but I don't understand why there is an update and shutdown option if it does not apply an update by that method.


New shutdown menu seen in the start menu.New shutdown menu seen in the start menu.


New options added in classic Alt+f4 dialog box.New options added in classic Alt+f4 dialog box.

Good morning @TheShaunSaw 


Thanks for your reply. As you may have seen in the screenshot I uploaded (and link here), I am seeing "update and restart" (every time), and I am selecting that option. I have not tried the Alt-F4 dialogue but in principal I should not need to... the system should update, and restart.


And that's the thing. It always says update and restart despite numerous attempts.


At first I wondered if there were some "backlog" of patches to be applied, but Windows Update claims that the systems is up-to-date. It does occasionally apply "Security Intelligence Updates", so that is working. The version-level of the OS has however not changed in months.


Any ideas would be welcome though I confess that I would not be thrilled with the prospect of fully reinstalling the whole OS.


Thank you for your consideration.

Hey @joedpconsultantsca,
did you manage to solve the issue? I'm facing the same problem.

Good morning@radkoa 



I am happy to confirm that I did overcome this problem. I am embarrassed to confirm that it was my own fault (or at least, it appears to have been my fault).


When I finally went to look, I found that that the switch to "Stop getting preview builds" had been turned on (see attached screenshot). Duh.


I don't remember turning it on (and thus blocking updates) but that was the reason. As soon as I flicked the switch, everything was normal.


I wasted two hours trying to solve the issue, and obviously I should have looked here first. I don't remember turning it off, no other person has access to my machine, so it must have been me.


Note that, depending on your build, this control may have moved. It used to be linked from the "Windows Update" page in Settings. In my current build (20170) I had to search for "Insider Progam".


Hope this helps.



Hi Joe @joedpconsultantsca,
thank you for your reply, unfortunately, this is not my problem. My switch is set correctly, I already tried to change the Release Preview Channel, I also tried to opt-out of updates (with restarts between changes of course). But without any change.
I found there are updates delayed for some AMD processors, but my system is Intel i7 (Dell XPS 13). Looks I'll need to do a fresh install :(

Thanks anyway!

@radkoa Please read https://aka.ms/timebomb