Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Memory Integrity Won't Turn On

Copper Contributor

I previously posted this on the Windows 11 Microsoft community but after following their advice I activated Windows Insider and downloaded 22H2 as the Microsoft online literature stated it was one of the requirements for Memory Integrity to activate automatically. But it didn't activate automatically.


I've cut and paste my post from the other community below:


Hi there.


I'm using a Medion Akoya Notebook and Windows Security is flagging that Memory Integrity is not turned on and my device maybe vulnerable. I noticed this flag before and went into Windows Security and flicked the tab to 'On'. The system showed it was running a scan for incompatible drivers, didn't seem to find any and then put up a notifcation saying something like 'To enable changes a restart is required'. I hit 'Restart' and my laptop automatically restarted itself. When it finished starting up Memory Integrity appeared to be on as there was no flag on Windows Security.

Now maybe a week or so later it appears Memory Integrity has somehow been turned back off again. When I run through the same procedure, as above, after I press 'Restart' my laptop begins the restart process but then hangs on the Medion logo before Windows 11 starts.


I don't understand why it keeps going off? I have not altered any settings that I can think of that would have effected this.


Could someone help me understand what's happening, why's it happening and how I could get Memory Integrity to stay on.


From my System Information I have the following:


Processor: Intel(R) Core(TM) i7-1065G7 CPU @ 1.3GHz , 1498 Mhz, 4 Core(s), 8 Logical Processor(s)


It has 8GB RAM and well over 64GB of SSD space remaining.


Would be glad of any help getting this turned on as I like to have things properly secured where I can.




**I followed a guide that showed me how to 'Refresh/Reinstall' Windows Defender and Switch the HVEC to 'Enabled' in the Registry. This didn't work. After the required restart my laptop is still hanging on the Medion logo before Windows starts up and I am having to press and hold power to turn off and on again to restart windows, but Memory Integrity remains off**


**I read somewhere that Hardware Virtualization needed to be On in the UEFI/Bios. When I tried to open the UEFI (Holding F10 on a Medion Akoya E15407) I first tried entering UEFI, but after selecting English as the language I then got an error message along the lines of "No image, contact customer service". Eventually after repeating and choosing the option below UEFI it entered what looked like a Bios screen and after side scrolling I noticed a line for Intel Virtualization which was marked as 'Enabled'.**


Can anyone please offer advice on how I can get Memory Integrity enabled? I like to have things as secure as possible.


Many thanks

21 Replies

Hello @Thomas_M82,


See if this video fix helps you:



Let us know if this helps!

Hi there @Kapil Arya 

Sorry for taking so long to reply. I've only just got round to trying this fix.
It was looking promising as the Memory Integrity button stayed on after I deleted the exact same driver you found in the video which was showing as a highlighted yellow. I also had one other highlighted yellow so I disabled this one rather than deleting.
But after hitting restart my laptop began the restart process but once again it hangs when it reaches the Brand logo for my laptop (Medion) and won't go on to start Windows.
I have to force shutdown by long holding the power button and then start up again. This time Windows loads, but the Memory Integrity remains flagged in Windows Defender as inactive.

Hi there @A1  Thanks for the advice. Sorry for taking so long to reply.
I have already asked in that area and they suggested I ask in here as it was something to do with Azure Directory, I don't know what that is, but the guy who pointed me this way suggested it might be related and that Tech Community would be a better place to try to find a resolution.


Only Microsoft engineers can answer, but they know it perfectly well and it is really a waste of time for further analysis (it seems that it is not possible to ensure the integrity of the system on very many computers for a long time)

Your computer is protected, and I assure you that currently the security of the system is at the highest level.

The user is the weakest point of security!

Best regards  

Go to you probertys and turn on your permitions then it will tomaticly activate


Thanks for the reply. I'm assuming you mean system properties? Where do I find permissions within this?


Can you explain in more detail what steps you propose?

Hey there @A1
Thank you for your feedback.
Everything else is working fine in Windows Defender and I have a decent virus/malware program.
So I guess memory integrity would be the icing on the cake but it's not vital though.
Thank you again.
If you go to the property's in defender and turn on your storage for defender it will access your memory and allow it to store on the device and you may have to do the same thing in your cloud.
You need to take the virus pertion softwareoff device windows has a virus softwear in the programing and it will not allow any other firmware softwere to be on device that is being ran by windows.


This is a private computer and has nothing to do with AD, and CSP, I think you'll understand.

@Thomas_M82 I am facing the exact same problem with my Infinix laptop which uses the exact same i7 processor as is mentioned by you.


When I hit restart, as is required in order to complete the process, it's always gets stuck at the Infinix logo and doesn't complete the restart process. Upon force shut-down, core-isolation remains turned off and that warning still there.


Kind of fixated on this issue and it's frustrating that I am not able to find a fix. Thought I may get some resolution online but it all has been a waste of time.


I really hope that Microsoft takes this matter seriously and give us a solution to what-ever this problem is.


Yes, it is pretty frustrating. It's a main security feature so surely it should just work!

I've had some people suggest it might not be working as I've got a virus protection package installed, but I don't see how that would prevent a supposedly hard wired security function from working.

I haven't been hacked or had any secuirty issues flagged as a result of it not being active, so I'm not overly worried. Though it is annoying how a standard feature isn't working.


Perhaps for some users, the following information can help to turn off or on the Core integrity.
I have a Surface pro 8 with i5 processor.
To install a program I have to turn off the Core Integrity.
This is only possible on my Surface pro 8 if I disable the Secure boot option in the UEFI bios.
Only then I can enable or disable the Core Integrity.


"To install a program I have to turn off the Core Integrity."

Yes, this observation explains (why even new computers have this feature disabled)

Best regards

hey i have the same problem with the same laptop. Have you found any solutions?

Hey, have you found any solution?