Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Windows Security doesn't show anything

Copper Contributor

I installed windows 11 from .iso. Now it is 21H2 build 22000.918.

The problem I have is that Windows Security app does not show anything like image. I cannot scan or do anything. 

I've tried pinned solution from @Dedtroit Windows 11 Security-Center not Working after Update from Windows 10 - Microsoft Tech Community but does not work. The Set-ExecutionPolicy cannot be set to Unrestricted (Get-ExecutionPolicy -List image is attached).

Is there any other solution for this?

tongvietdung_1-1662902975931.png

 

tongvietdung_0-1662902806377.png

 

10 Replies
Open start and search for feedback and open the Feedback Hub app and report this issue.
Try open the Windows PowerShell and run the following command:

Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage

Also run Windows Update and download and install all updates.

@Reza_Ameri 

I've reported through Feedback Hub.

PowerShell command didn't fix the problem and my Windows is up to date.

Open command prompt and search for cmd and right click and run it as administrator and then type the following command:

sfc /scannow

Press enter and let it runs.

@Reza_Ameri 

It also doesn't work

tongvietdung_0-1663070626167.png

 

Try performing Clean Boot and see if the problem persists?
Have a look at:
https://support.microsoft.com/en-us/topic/how-to-perform-a-clean-boot-in-windows-da2f9573-6eec-00ad-...
Unfortunately Windows Security still doesn't show anything
Make sure report this issue using the Feedback Hub app as I mentioned earlier.
Are you able to open other Microsoft Store applications?
Are you able to open settings?
Try run Command prompt as administrator and then run the following commands:

DISM /Online /Cleanup-Image /CheckHealth
DISM /Online /Cleanup-Image /ScanHealth
DISM /Online /Cleanup-Image /RestoreHealth
None of those thing works for me
Microsoft Store and Settings app work fine
Do you have access to the Windows installation media?
I believe you have to perform a repair install or new installation.