Windows 11 Printer Issue - DYMO LW450 DUO is not installing correctly/entirely

New Contributor

This issue occurs in Windows 11

The expected result is that both DYMO LW450 DUO Label and LW450 DUO Tape install correctly, however only the LW450 DUO Label installs while the LW450 DUO Tape's status is displayed as "Error". The device was connected with USB.

There seem to be issues with other manufacturers (Brother, Canon, HP, etc.) when installing multiple printers/scanners and the root cause of this instance may be related

Please respond regarding the status of this issue or workarounds for Windows 11.

Thanks,
David
DYMO Development Team

 

PrintersAndScanners.png

 Win 11 version.png

98 Replies

@Joachim_Fink 

There is a nice manual form Dymo that describes the complete proces.
You can find it on: 

https://download.dymo.com/dymo/user-guides/Print_Server/LWPrintServer_UserGuide_en-US.pdf

 

This manual is written for the Dymo Printserver, but it works also with other prinservers.

Only really useful if you have a DYMO LabelWriter print server. What we really need is a Windows 11 fix for this massive problem.

@Joachim_Fink 

 

Indeed ! ca.  £100 + to add a print server on top of the existing cost of the printer is not a very appealing solution. But it is interesting that it has been shown to work and to my mind demonstrates clearly that the issue is with the OS' handling of the USB port interface.

Best regards,

Kevin

Well, well, well !!

I have just updated overnight to Win 11 Pro Insider Preview Build 25145.rs_prerelease.220617-1406 and find that the Dymo 450 Duo is working as it should with both Paper Label and Tape seamlessly selectable from Dymo Label v.8.7.4.48936 !!!!

I hope it will continue to function normally now and I'm not speaking too soon - but it appears that MS have FINALLY managed to untangle the USB muti-function device handling and restore normal service. ONLY 6 months......

 

Assuming it continues to work OK, just need now for the code to work its way through to (presumably) the 22H2 General Release.


Best regards,

Kevin

Apparently this "22H2" update is coming from Microsoft in October 2022. Halle-blooming-lujah!!
So I suggest we don't post anything until 22H2 hits your computer./
I’m on OS build 22622.290. Is this version of Windows supposed to work properly?

@megatech1966 

 

I don't believe it does. The earliest build I had the printer working successfully with was as per my post above...    (Win 11 Pro Insider Preview Build 25145.rs_prerelease.220617-1406 )

 

However, yesterday I discovered that it has stopped working again and am suspicious that the latest update which MS dropped on Tuesday this week (25151) has messed it up again. I'm planning to try and roll back to see if that resolves and can confirm.....

 

Best regards,

 

Kevin

I installed Windows 10 on my Nvme drives. Dual boot. Dymo software worked once. Then doesn’t after that. I don’t think it’s just a Windows 11 problem.

I don’t think it just a Windows 11 problem. Tried Windows 10. Worked once then doesn’t work after that. Looked at the drivers. It says further installation required. Just like on Windows 11

I agree, this problem already started in Windows 10 for me, somewhere in oktober or earlier.
A week or 3 ago I managed to make it work in Windows 11, it worked until I rebooted.
Dymo Label Writer 450 and 450 Duo with work on Windows 10 (any version).

They WILL NOT work on Windows 11 Home. They will work on Windows 11 Pro and Enterprise.

Hope this helps.
I have Windows 11 Pro and it doesn’t work for me. I have a 2015 Mac Book and it works fine.
@NoelPMaguire - Can you clarify which version you have managed to get it to work with 11 Pro please ? My experience has been that it started working again OK when Win 11 Pro Insider Preview Build 25145.rs_prerelease.220617-1406 was issued but stopped functioning again when Build 25151.rs_prerelease220625-1835 was dropped a week ago.....
Best regards,
Kevin
We have also experianced this issue but on Windows 10 machines. We have found that it has been caused by the update KB5015807. Uninstalling that and rebooting resolved the issue. We had this at multiple companies and users that we support and this worked for all of them.

Hope it helps others
Is there a way to uninstall that update when it’s not on my history list?
As a regular Joe, I just want my Dymo printer to work with Windows 11. Is that too much to ask from the mighty Microsoft
Exactly. Not just Windows 11 but Windows 10 as well. Very disappointed.
*** Goggle Translate ***
I couldn't find any good news at DYMO:
https://www.dymo.com/compatibility-chart.html
Nor on the side of the SDK developer site:
https://developers.dymo.com/
Why does it work with a version of Win 11 and not the latest? That does not make sense ! Finally, nothing is clear!
*** Texte original ***
Je n'ai trouvé aucune bonne nouvelle chez DYMO :
https://www.dymo.com/compatibility-chart.html
Ni du côté du site des dévloppeurs SDK :
https://developers.dymo.com/
Pourquoi cela fonctionne avec une version de Win 11 et pas la dernière ? Cela n'a pas de sens ! Finalement, rien n'est clair !
Hopefully Microsoft will come up with a fix
Updat on Sat 16th July.... Win 11 Pro Preview Build 25158.rs_prerelease.220708-1401 has just been installed and sadly makes no improvement. The paper tape printer is recognised but not the tape this time. I have done the usual full uninstall-reboot-install-reboot routine and also attempted to manually configure the device port settings (which has had some limited results in the past) without any joy.