Windows 11 doesn’t recognize an m.2 NVMe in a pcie slot after upgrade

Copper Contributor

Hey all,


Bought a new HP Omen 30L-1139 it has expansion slots for upto 3 m.2 SSDs. I swapped out the 2 SSDs from my old computer to the new one and everything worked as it should. I had this working for over a week, then when I upgraded to windows 11 and a new bios update, well, windows 11 doesn’t see the 2nd M.2 SSD plugged into the pcie slot.


I can go into the bios and see the ssd in the pcie slot, no way to activate it or anything like that if needed. When I go into wing, not detected at all, not under disk management, or partition either.


stumped on this one. Tried to reach out to HP; howe

14 Replies
Looks I have a similar issue on my Dell T7820. The nvme in the flexbay is not available under Windows 11. I have excluded BIOS problems since the device works under windows 7.
The device manager indicates under "other devices" that there is no raid driver installed. Dell online diagnostics comes to the same conclusion and proposes a driver to install. When I do so, the drive in the flexbay is immediately accessible and works fine until shutdown. During restart a bluescreen indicates that the driver is not working and only getting back to the last restauration point allows me to run windows again in the above described state with no access to the nvme drive in the flexbay.
This is what I learned up to now.
The question for me is now, where to get a driver which is working under windows 11.

Dell will you come up with one, which is in turn passing microsoft requirements and will be included automatically in winfows update ?
For the time being windows 11 keeps telling me there is no raid driver for the nvme in a Dell T7820 flexbay.
Typo in the begining of my post: the device works under "windows 10" .



Well, after a few weeks of experimenting myself, the only way I got it to work was to remove the SSD and reinstall windows 11. When that was done and all upgrades completed I reinstalled the SSD, now it finally recognizes it. Took me allot of trial and error to get it to finally work. I even tried the disk HP sent me. It didn't work either. I had to use the window setup from Windows itself, well all that did was format one of my SSD with all my stuff on it. 


Suffice to say, remove the spare ssd from your computer, upgrade it or reinstall Windows, when that's done reinstall the SSD, it should recognize it then.


Good luck!

Thank you I appreciate your answer. I have done this as well. Windows update cannot find any appropriate driver. Dell diagnostics tells me there is no driver installed and the one they propose leads to bluescreen on reeboot. I am working with the Dell user community on the subject which seems specific to Windows 11 since rverything is working with Windows 10.



completely agree, windows 11 apparently isn’t even in Beta testing yet, but still released. 

when I was testing, I actually bought a powered m.2 NVMe adapter for pcie slot. It was just super weird trying every single combination then this eventually worked. HP was even going as far as using it as a test bench for them to see. Never heard the end result either. They still don’t know I solved the issue myself. I would chat with them and then at the end of the chat they’d close the ticket, even though no solution was found. Even receiving e-mails from the supervisor. I’d reply with photos of the bios seeing the ssd but not in windows. They never replied to my replied E-mails. so they didn’t help me, so I’m not updating them, lol

@Loadie So are you saying that the nvme M.2 is an issue with windows 11, and you advice not doing so just yet. I just bought the Asus z690 creator board with 4 m.2 slots and wanted to run raid 10 1tb each hard drive. Loaded windows 10 no problem and then was gonna raid 10 but decided to load windows 11 and it errors, won't load? frustrating. I really don't want to pull the drives out to load the windows 11 to find out later the updates are not working properly as well? 

Any tips on setting up raid 10? Never setup raid before and have no idea what to do to make it happen?

Sorry, none that I can think of! I returned the computer to HP and built my own. I’m still running Windows 10, but can easily upgrade if I want. Just not willing to take the plunge quite just yet, lol my new system easily runs all 3 of my NVME M.2 SSDs now.

@LoadieThank you for your reply. So I spent right much to build my own and was very disappointed to find out that windows 11 is an issue with the nvme ssd m.2. Frustrated after buying 4, 1 tb nvme to work in my new Asus proactive z690 creator mb. I just purchased 2 different dvd's of the windows 11 pro only to find this out? I will be in contact with Asus 2nd lvl tech engineers and will either speak with or get email reply about this within 48 hrs,

hopefully? If anything becomes of this I will post the results. Again thanks for your prompt reply.


Give it a shot with Win11, what will it hurt? If you have to just remove win11 and reinstall win10. I believe it was an issue with the motherboard HP has.
Looking for some help on similar issue. I have an HP Slim Desktop with 512GB m,2 primary drive and 1TB secondary HDD. I am unable to add a 4TB Crucial m.2 NVMe via PCIe or using a USB adapter on Windows 11 home edition. It shows up in the disk mgmt dashboard as unknown and when I try to initialize it, it fails to initialize it with a fatal error msg. I have tried 3 brand new Crucial m.2 NVMe drives (all 4TB) and they all fail to work on the system. Any insights on how to resolve this would be very much appreciated. HP is unable to provide meaningful assistance.
Have a look at your motherboard manual or Google search the capacity of SSDs on it. Some will only allow upto 2GIG SSDs.


Thank you very much for your response to my email. I will look into it. In the meanwhile, I have a 8 TB SATA Seagate external USB drive that works just fine on this system for my backup however the internal 4TB m.2 NVMe is the one that seems to have some issues even using a USB enclosure. Would they behave differently between m.2 vs SATA/USB? Thanks again for your response. 



They very well could; However, I have no idea. That info should be with the MB documents. The other thing to try is the MB manufacturer forums or trouble shooting. I wish I could offer you more,advice, I’m simply an end user and virtually had to send back the computer to HP for a full refund. I built my own and haven’t had an issue since.