USB Audio Codec drivers not recognized unless Settings>System>Sound Troubleshooter runs

Occasional Contributor

I am setting up a new computer with Windows 11, which I am new to. I have two different applications that use the USB Audio Codec connections to receive and send sounds. When I first start the computer, neither of these apps is getting audio from Line-in; Output works fine. On the Sound>Mixer page, the apps do not appear. I can see that input audio is available because the Volume level indicator on the System>Sound page is moving back and forth. If I run the Sound Troubleshooter on the Input Devices, it tells me it is reinstalling the device drivers. After that, both apps work and get audio in; the Mixer page shows the app. However, when I restart the computer, I am back to square one with no audio input to the applications. Under Windows 10, this exact setup worked perfectly. Any suggestions? Thank you!

6 Replies
Try check your device's manufacturer website and download and install the latest driver.
Try run Windows Update and download and install all updates.
Open start and search for feedback and open the Feedback Hub app and report this issue.
Thanks you. I have the latest drivers from Silicon Graphics. Windows update fixes the problem until the next time I restart, the I have to run Windows Update again. On the Silicon Graphics community board there was someone else who has exactly the same problem I am having. He switched the Com Port from 3 to 1 and that resolved it. I have tried changing com ports for my drivers but didn't have any success
In this case, I advise you to report the issue using the Feedback Hub app.
Try performing Clean Boot and see if the problem persists?
Have a look at:
https://support.microsoft.com/en-us/topic/how-to-perform-a-clean-boot-in-windows-da2f9573-6eec-00ad-...
Will try a clean boot, but I may be in over my head trying to find the problem. Silicon Labs (driver manufacturer) also thinks there may be an interfering program on reboot, the the Troubleshooter in System>Sound corrects
I tried a clean boot and the problem goes away. Appears to be one of the system devices causing the problem. Can you walk me through the steps of enabling and disabling individual devices? I'm not sure I am doing it correctly. To do the original clean put, I used msconfig, went to the services tab, select "Hide all Microsoft services", select disable all, then select Apply. On the startup tab, I disable all enabled items, then restart. That is how I am doing the clean boot. Now how exactly do I go in and selectively enable each service? Select Hide all Microsoft Services, click? Select a service then restart? Do I have to select apply? It;s a little confusing. Thanks for your help!!
I think I found it. Looks like two services, Waves Audio Services and Waves Audio Universal Services, are messing with the Silicon Labs USB Audio Codex drivers. Disabling those two services "seems" to have fixed the problem. Need to track for a few days