RS232 Serial port - PL2303 RA Chipset Issue with Windows 11

New Contributor

Under Windows 10 we can use the PL2303 TA chipset that was always rock steady over long periods of time, but with Windows 11 the TA chipset is no longer valid to use and we have had to use the RA chipset instead, but after an update in Windows 11 earlier this year, they work for a while and then disconnect/fail, whereas previously we could leave them running for long periods of time without them missing a beat. I have tried installing an earlier version of the driver so that the TA chipset can be used, but it reacts like the RA chipset and after a while even they disconnect/fail.

 

We have tried changing Windows 11 Power settings so that it doesn’t go to sleep or disconnect USB connections, stop hard drive sleeping etc to try and resolve the issue, but none of these work for us. 

This is a bit of an issue for us as part of our job is to monitor devices for potentially long periods of time thru a serial connection.

 

Has anybody any ideas that might resolve this issue for ourselves, apart from rebuilding all our machines in Windows 10.

 

Thanks, any help would be much appreciated.

0 Replies