No app thumbnail on taskbar

Copper Contributor

Hello!

I noticed that whenever I open an app that's not pinned on my taskbar, it would show up like this.
I have a screenshot with Spotify, for this example. 

 

There are some other situations where it would pop up normally. Right next to the Spotify app, there's Discord. The app isn't pinned on my taskbar as well, but whenever I open it, the thumbnail shows up properly.

 

spetimus_0-1659774158264.png

 

Is there any solution to fix this problem, so that the apps would show up properly?

 

Thank you! :)

5 Replies

@spetimus wrote:

I noticed that whenever I open an app that's not pinned on my taskbar, it would show up like this.
spetimus_0-1659774158264.png


Hello @spetimus,

 

Try resetting icon cache (works in Windows 11):

https://www.kapilarya.com/how-to-reset-icon-cache-in-windows-10

 

Let us know if this helps!

 

Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.

Hello @Kapil Arya,

 

Thank you for your suggestion!

I tried it moments ago but I still have the issue, whenever I open a new app that's not pinned..

I wanted to chime in and say I have the same issue with Spotify. Recently upgraded from windows 10 pro to windows 10 pro. I tried the suggestion of clearing file explorer's icon cache. Did not fix it.

@spetimus 

Thanks for sharing the issue!

Spotify_icon-icons.com_66783 (1).ico

There is one way to change the icon manually!

1. Right Click App on Taskbar.

2. Right Click name of App.

3. Click Properties.

4. Click "Change Icon".

5. Locate the download .ico file and press enter, apply, save and exit. Restart computer.

 

@spetimus I managed to fix it. For me it seems like the issue is with the shortcut to Spotify not Spotify itself. Here is how I fixed it:

 

1. Search -> Spotify -> right click the icon

2. from there, select open file location, this should bring up where the shortcut to Spotify is saved.

3. After that, right click the shortcut and once again right click -> open file location

4. Now you should see the actual app and not the shortcut. Unpin the old icon and close Spotify

5. Then, right click -> pin to taskbar on the direct app and the icon should return. Hope this helps!

 

I also tried the directly changing icon mentioned elsewhere in the replies but nothing seemed to change.