Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

msiexec.exe errors

Copper Contributor

Since some recent windows 11 update (if I re-install windows pre from a support-led iso it is OK) I can not install/uninstall or update various third party programs (popular ones like Paint.net, charles Proxy etc.)

I may get msiexec.exe Application error. The application was unable to start correctly (0xc0000142)...

or I get (1601) The Windows Installer Service could not be accessed.

 

But windows support refuse to deal with msiexec failures because... third party programs.

 

Any known issues/fixes?

 

Note Windows Installer Service is not running and I can not make it run

4 Replies
I have this exact issue too. Trying to start the Windows Installer service will also not work for me.
I've tried everything except re-installing Windows.
@jantje19 Reinstalling windows was the only that that worked for me unfortunately. Microsoft support was not very helpful on this issue - though eventually they did tell me how to do this

I seem to have fixed it!

When I started msiexec.exe in a debugger, I noticed a message about application verification. After some googling, I started appverif.exe. I added msiexec.exe to this and then pressed 'restore to defaults' and removed it again. After that everything works

It means your windows is corrupted. You should reinstall windows again and try. Before Installing any program make sure you have installed : https://aka.ms/vs/17/release/vc_redist.x64.exe. And also try to run "sfc/scannow" in windows terminal as administrator.