Mouse and USB audio random hangs

Copper Contributor


I have got a brand new MSI MAG Z790 Tomahawk DDR4 paired with i7-13700KF, installed fresh, Windows 11 - (22H2 22621.755).

Every now and then I will get random USB headset to sort of hang / freeze.

Sound stops playing, but headset RGB remains lit, and I can see in the system that it is connected, plugged and working in device manager.

Additionally, I also find similar behavior of Asus ROG Gladius III mouse.  Here, the cursor will hang, but mouse RGB is lit, and device manager says it is working properly. 

To get those to work again I have to unplug and plug back in. 

Thing is that I have got other devices connected to USB and those are fine. (Keyboard, HOTAS, and 3 other HID's) 

I tested two distinct headsets, and both experienced the same. I have got all drivers / device firmware (mouse and one headset) / BIOS, up to date, tried with and without software, tried uninstalling, reinstalling, etc. No matter what USB ports, rear or front, 2.0, 3.x. ...


I went through MSI support procedure, provided extensive logs and they said all is good (?)



16 Replies
Try open start and search for feedback and open the Feedback Hub app and report this issue.
Try performing Clean Boot and see if the problem persists?
Have a look at:
If no, enable services one by one to identify which one causing this problem.
Hi Reza_Ameri.
Thanks, I uninstalled the feedback app I think as I can't find it. I tend to slim down my Win OS always, so it is likely that I did.
Anyway, wouldn't this portal be the right place to report as well?
I tried clean boot, the moment I did I experienced the issue with my mouse.
There is just a bunch of "non-Microsoft" services, mainly Asus (mouse) and NVIDIA service responsible for tray icon. There is one Intel service and a few others (steam, nzxt cam, GOG) BUT the issue was present BEFORE I installed those.
So, simply put, clean boot is not helpful here. I noticed one additional thing last night though and will give it a test again, when I plug in USB headset after Win OS is loaded, I can be almost certain that issue with audio will manifest itself. Even reconnecting the headset and restarting the game helps for few minutes only. However, if I get the issue the first time, and reboot my PC with USB headset plugged in, it seems I don't get the issue anymore.
You may open the Microsoft Store and search for Feedback Hub app and download and install it. Sending Feedback would help the Windows team to become smarter and be able to investigate the issue. This portal is also a good place to report but Feedback Hub is able to submit log files and other users with same experience are able to upvote it.
Try check with MSI's support too.
Have you tried connecting to a different USB port?


MSI collected logs and provided no other resolution than - "go to the retailer and ask for a replacement board as it might have faulty USB port"
Yes, I have tried all ports. It fails randomly so I it's also not an ideal for troubleshooting.
Last night though I had something else happen as well. While in game (Cyberpunk main menu) my audio dropped, my keyboard stopped responding and so did mouse. Each device still displayed RGB lights on them but were otherwise unresponsive. I unplugged each one by one and plugged again only to find out that none of the RGB came back. Devices appeared not connected. After a reboot (via case power switch) I noticed a new entry in the Event Log:
"Connectivity state in standby: disconnected, reason: NIC compliance", so by documentation: This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.


I am now thinking, maybe my 12 years old Antec True Power Quattro 1200 is finally giving up? 


Just to be on the safe side, I ordered a new SEASONIC PRIME GX-1000, once delivered, I will replace and see if I am any better. If not, at least I will know the good ole' Antec is still up to the job.


Thanks for you inputs!

I am wondering, have you tried Safe Mode?
Did you observe the same result?
There is a possibility that it might be a hardware issue.
It is also good idea to send feedback because it contains log files and would help the Windows team to investigate the problem.

Yesterday and today I also received a notification that there was a problem with USB-C. I went to read the article, and everything was pointing to the insufficient power in the system.
So, last two days it wasn't intermittent anymore, it was the worst of all times, with mouse freezing, USB dropping out few minutes of reconnect, not only in game but also in OS, while doing simple tasks - Excel, Outlook, web browsing.
Today my new Seasonic arrived. I installed it and had no issue so far, even during one hour of my gaming session, will continue with tests, but it does look much better. We will see. Thanks Reza.

Great, thank you for the update and I hope it solved the issue.


Well well here I am again. 

The new PSU did not help. At least I have a new piece of hardware now. 

I logged the case with MSI as I have got any USB devices randomly reconnect. No longer just mouse or audio. Its actually any device that I connect to ANY USB port. 


MSI did not help, offered me that I should send the mb to seller's service. 

I saw many other posts about USB disconnecting, and that is across boards brands and models, even in Z690 chipset. I no longer think I am alone with the problem. All these months I tried various troubleshooting options, workarounds and whatnot, but problem is still there. 

I replaced USB peripherals with new ones, replaced the USB power HUB, changed cables, reshuffled connections on the back I/O. 

My current testing is to move four devices to another powered HUB that connects to USB-C as so far I tested only USB-A ports. However I keep low expectations for this. 

Nothing helps.

The common symptoms I get randomly include, but are not limited to:

  • voice and sound corruption over the USB headset,
  • stuck or delayed text typing / key pressing,
  • device disconnected / device connected message coming from third-party software,
  • mouse cursor freezes / button mis-clicks.

Issue can happen to any device at any given time with no obvious pattern.
It does not matter:
- how many devices are connected.
- which device is connected to which port.
- which USB revision - USB 2.0, 3.x, USB-C.
- what is the PC workload - game, simulation, creative software, desktop, youtube or any other tube.

Here is a list of things that I have tried so far.
- the USB audio headset with a different brand.
- wired USB mouse with a different brand.
- the power supply with better quality, more wattage and newer design.
- USB active hub with a different brand.
- Windows 11 22H2, even tried Windows 10 22H2, with same results.
- BIOS 7D91v12, 7D91v13, 7D91v14.
- chipset drivers.
- USB drivers.
- software, drivers, and firmware for all devices I use.
- Windows power plan to Ultimate performance + USB Selective suspend setting = disabled
- Device Manager - Allow the computer to turn off this device to save power for all applicable devices under Human Interface Devices and under Universal Serial Bus controllers nodes.
- EnhancedPowerManagementEnabled = Disabled (0) for each applicable USB device in the registry.
- Disabled the Human Interface Device Service in Windows services, to ensure keyboard functions were not to blame.
- CPU C states, USB legacy, USB XHCI hand-off

@Gierasimov My USB power in my power settings on all power settings was set to suspend.  Z790 Gigabyte DDr4 Elite AX board with 13700k.  Why is this on by default when it wasn't on my Z590 Aorus Pro AX?  I have been having the same problems streaming youtube videos and getting disconnects on all my USB devices and sound of course drops with a buffer on the video.  I don't know if this will fix my problem but I just noticed it.  


Just went in and disabled it the USB setting.  I'll have to wait and see what happens.  I have many devices connected to my system.  2-3TB Toshiba HDDS , 1-TB  SSD, 1TB PCIE 4.0, NVME, 512GB PCIE 3.0 NVME, 6800XT, 32 GBs 4 sticks B-Die RAM, Xbox Controller USB-C, Kraken USB Headset, Razer mouse and keyboard, WIFI 6E device, NXZT 280mm Radiator.   Is this a PCIE lane problem?  I can hear my drives kick on and off as well when this goes intermittent. 



I ended up buying an Asus Z790 board and all my problems are gone. 

Could not stand constant uncertainity with the MSI board. 


These Z790 boards seem to not have the quality as Z590 boards. 


I went into my bios and even after resetting the bios to default the PCIE Lanes were showing gen 3 status instead of gen 4.  I changed it to auto and the problem seems to have went away on my end.  I went purchased another headset just to see if it was that but it wasn't as it was still doing the same thing with 3.5mm as well.  


I have been testing after changing the bios setting to auto on the gen lanes and it seems to be working finally.  I was even getting wifi 6 problems which is why the the disconnects were happening between the PCI lanes.  I don't know why this was set this way by default on the board.  Asus boards on the low end are very cheaply made.  All of them really are if you ask me.  The Z490 and Z590 boards are built much better imo.  

After a few days of researching the problem the culprit was Gigabytes own software causing the problems. After deleting Gigabyte Control Panel and Gigabytes other software it downloaded and installed through the control panel such as RGB updates, drivers, the problem with the USB disconnects are now completely gone. This is TERRIBLE on Gigabyte's end. I have had many Gigabyte boards x470, z590, 970, and never had any problems until I purchased this Z790 Aorus Elite AX DDR4 board. This board does cost around 280$ USD and isn't built near the quality of my Z590 Aorus Pro AX board for the same price. The board seemed as if it was rushed before quality had a chance to test it. I would advise anyone to stay away from this board especially at this price range.



I'm faced with the exact same issue. 

I have read the exchange on this thread. 

I need to know the simplest way to rectify this. 

With hindsight available, wondering if anybody can offer help.

Thanking You. 

Let me know if any specific system related information is needed.

I had to replace the motherboard for a different brand. No issues since.
As I mentioned earlier, first try Safe Mode , in this case it prevent most third-party programs and drivers to load and if your device work, then we could investigate and find out what causing the problem.
However, if the problem persists in the Safe Mode, that would be more complex and it might be hardware issue too but there are ways to investigate it too.