Windows Modules installer worker

%3CLINGO-SUB%20id%3D%22lingo-sub-2134055%22%20slang%3D%22en-US%22%3EWindows%20Modules%20installer%20worker%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2134055%22%20slang%3D%22en-US%22%3E%3CP%3EHey%20tech%20community%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20legion%20Y540%20windows%2010.%20I%20recently%20updated%20to%20the%20latest%2020H2%20(%20not%20sure%20if%20am%20correct%20with%20the%20version)%20after%20that%20I%20saw%20a%20gradual%20drain%20of%20my%20laptop%20battery%20%2C%20it%20gives%20me%20hardly%20an%20hour%20over%20battery%20and%20i%20saw%20what%20was%20consuming%20this%20heavily%20and%20found%20that%26nbsp%3BWindows%20Modules%20installer%20worker%20is%20continuously%20running%20and%20draining%20the%20battery.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20checked%20online%20and%20found%20out%20it%20might%20be%20trying%20to%20install%20updates%20%2C%20I%20tried%20updating%20and%20everything%20%2C%20the%20result%20is%20still%20the%20same.%26nbsp%3B%20Oh%20I%20have%20already%20tried%20going%20to%20services%20and%20setting%20it%20manually%20and%20all%20.%20I%20am%20thinking%20is%20it%20just%20for%20me%20.%20I%20am%20planning%20on%20resetting%20the%20OS%20and%20see%20what%20will%20happen.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hey tech community,

 

I have a legion Y540 windows 10. I recently updated to the latest 20H2 ( not sure if am correct with the version) after that I saw a gradual drain of my laptop battery , it gives me hardly an hour over battery and i saw what was consuming this heavily and found that Windows Modules installer worker is continuously running and draining the battery.

 

I checked online and found out it might be trying to install updates , I tried updating and everything , the result is still the same.  Oh I have already tried going to services and setting it manually and all . I am thinking is it just for me . I am planning on resetting the OS and see what will happen.

 

Thanks in advance!

1 Reply
Hi,
have you tried leaving it on for few hours or during night time to see if it finally finished whatever it's doing?

after that Reset is a great option