Microsoft Store

Occasional Visitor

Right. I'm having a few issues on my Microsoft store. Here is a list of my problems:

 

1. It doesn't open

2. Wsreset doesn't work 

3. The app is not listed on the apps on settings>apps

4. PowerShell does not fix the problem

5. Restoring my pc doesn't do anything about it

6. All YouTube tutorials don't work at all

7. cleaning and removing malware to fix the problem doesn't fix the problem

8. No apps pop up when it says "you need an app to open Ms-Windows-Store-Link"

9. Making new accounts don't work

10. It says the file has been moved in some way

 

I need expert help on this subject and would really want to know how to fix it without having to factory reset my pc.

 

Thank you,

Alfie Baker

9 Replies
Hi,
so you've tried lots of methods to fix it but they all failed,
I suggest to perform a Reset, I know it's not what you want to do but it's guaranteed to fix it.
the problem could have been caused by a 3rd party program or user settings.

also, are you on latest Windows 10? (latest version is 20H2)

I am having the same problem. Since updating 4/23/21 Store will not open. Feedback hub will not open. One note windows 10 will not open unless I print to Windows One Note 10 and then opens only some of the time. None of the fixes mentioned has worked. Using Windows 10 latest version.

Yeah I suggest performing a reset

Assume you mean Windows 10? This will destroy all existing apps and make hours of work for me? Other random irritating issues arising and am too busy working to reinstall all.

@HotCakeX 

Hi And what happens when you enter the address of the MS Store and there you log in with a Microsoft account? Since the installed application does not work, but directly from the site you can download a new application, etc. Of course, the default browser is Edge which will confirm your identity in the MS store and there is a high probability that registration in the Microsoft Store will restore the correct registration and hosting of your device! Good luck.
Now I read that you have information that the application has been moved and this is a very likely cause of your problems - if it is not in the C folder it will not work for sure! another possibility of repair is to find where - on what disk was moved and this fix and restore to folder C is a key solution for you-so I think!
That sounds correct. Can you tell me which files I am looking for?

Actually fixed it by restoring from a previous point which failed and then undoing the restore. For some reason that allowed me to access the store and update all the programs that were failing. Makes almost no sense to me. Perhaps the moved file was replaced? I appreciate your help sincerely. All seems to be working just in time.

Hi, if I understood the system restore well helped - that's great news!

Thank you very much 

Andrzej