SOLVED

1703->1709 BSOD 0xc00000bb on devices with NVMe SSD's

Occasional Contributor

1703->1709 BSOD 0xc00000bb on devices with NVMe SSD's

 

This will be the very first question I will ask in the AMA.  I hope you have a better answer than "we are working on it" ready for the thousands of us with this issue and waiting for a fix since September.

 

https://social.technet.microsoft.com/Forums/en-US/08485ba0-f69f-483b-861e-238f161dabee/problem-with-...

222 Replies
best response confirmed by Steven Rodriguez (Occasional Contributor)
Solution
This is a known issue. The fix for this will be included in the cumulative update that will be released today at 10am via http://catalog.update.microsoft.com (manually downloaded). It will also be included in the next Patch Tuesday cumulative update. (Ref OS #14207031, 11D)
The suggestion I received from many employed by MS was to simply format and re-install Windows. This isn't an option, I run a highly customized system with many apps. A full reinstall would be a tremendous effort, the in place update really needs to work.

Thank You very much for addressing my question.  I am happy that this was resolved and am excited to finally be able to try FCU.

@Michael Niehaus

 

I've been watching the Windows Update Catalog website all day, as of this writing (4:43PM) I don't see it.  I'm using the search term "windows 10 cumulative update" and the most recent results are dated as Nov 29th, but they show as being for Build 1709.  I would assume by what you suggested we would be seeing a Cumulative Update dated for today, Nov 30th with Build 1703 in the description.

@Michael Niehaus 

 

Can you tell me what the KB number is for this patch please?

I don't think so, the KB applies to 1709, the patch we are looking for should be applicable to 1703 as we can't update to 1709 because of the NVME SSD issue.

The fix is needed to the Windows 10 1709 installation files, not to Windows 10 1703.

 

If you are using dynamic update, the fix should automatically be injected during the process.  Otherwise, you might need to manually mount the install.wim and inject the update into it, at least until January when we'll be releasing updated media that will contain the fix.

@Michael Niehaus I am not sure what you mean by a "dynamic" update but I am assuming you mean through an automatic mechanism.  I tried the upgrade again using Windows Update, and I get the same BSOD after it tries and fails to update with the "Feature Update to 1709" update.  I also tried the Windows 10 Update Assistant application which re-downloaded the media and also failed with the same BSOD on the first reboot.

 

Either I am doing something wrong, or the patch was not issued by Microsoft.  I have to say this is extremely disappointing.  A solution was implied, and none was given.  Please Help.

Seems to me, what hes basically saying is that the fix that should have came out on the 30th which never did, then the update for the 30th came out on the 5th on Tuesday which still does not contain the fix & now we'd have to wait till January for the "fix" which probably won't come again.

 

Seriously it's very disappointing, everyone out their is complaining and nothing is being done.

 

I built a new pc just 3 months ago and knew win10 would be very troublesome, that i literally bought an ssd just for the OS to to prevent deletion of important files because fresh installs are the only thing that temporarily fix things like this. 

 

It also stopped my antivirus & nvidia drivers from working that i had to delete both apps and reinstall to my other ssd.

These constant promises from Microsoft without a fix is just getting ridiculous already.  I have tried updating to 1709 in every possible way.  From Windows Update, to ISO, Upgrade Assistant, etc.,I have tried them all and nothing works.  Every time you try to reboot you get error 0xc00000bb.  There is no fix from Microsoft out there, and it does not look like there is going to be a fix.

Does Microsoft really want me to go and buy an Apple and be done with this.  I am sick of waiting for a fix for something that is a common problem for people trying to upgrade with a SSD drive.  

Can someone from Microsoft please tell us if there is going to be a fix or not, and what is the timetable ?  I really would like to know a fix is really coming or not. 

@Michael Niehaus A lot of very angry people, Michael.  Can you please bring this to the attention of whomever can provide a solution.

Microsoft seems to treat this like there is a couple of hundred of us here complaining,and no one else has this problem.  Well, in reality I cannot tell you how many people have this problem. I have heard from countless other people that cannot upgrade to 1709. Why in the world is it so difficult to put out a fix after about six weeks of this.  All we are asking is to be able to upgrade to 1709.  

I am at my end with this.  I have tried every method of upgrading.  Other than doing a clean install, which I refuse to do, it is impossible for people with SSD drives with NVMe to upgrade. 

You can also do the workaround, which is to clone the NVME drive to a SATA drive, then boot from SATA, do the 1709 upgrade, then clone back to the NVME.  Many have done this successfully, I just can't be bothered.

You mean you can simply copy 1709 from your SATA to your SSD after upgrading and everything works fine.  Sounds like a lot of work, and it will open up the possibility of many errors.  I just cannot understand why this is such a big fix for Microsoft.  Lots of people a lot less computer efficient than us are having this problem.  I wish they would just issue a fix already. 

Not copy, clone.  As in using a 3rd party tool like Acronis or something else.  The only downside I could see if the hardware change from NVME->SATA->NVME would trigger a hardware ID change and make all installed software unregistered and ask for re-activation.

You see.  You are already coming up with a possible problem.  I cannot believe all this time, and not one engineer at a place like Microsoft can actually come up with a fix for this.  Just unbelievable. 

I've been reviewing this with support engineers.  It appears that there are two separate problems, one that was fixed with the update released on November 30th (affecting a small number of devices with Intel P4500/4600 drives), and a second one that is still being worked on (affecting certain X299 motherboards).  We still have a block in place for the affected devices so that Windows Update doesn't try to upgrade them.

 

For the machines where you are seeing this issue, can you provide the make and model of the machine, or if it is a "build-your-own" device, what model of motherboard is being used?

 

The second issue (X299 motherboards) can also be fixed with a firmware update; the fix we are working on just tries to work around the firmware issue.  We are trying to work with the motherboard makers to have them create a firmware update.