Teams Live event RTMP server disconnecting

Copper Contributor



Tonight we have a webinar at my work. I found out that with a public live event in teams u can use a external RTMP encoder like OBS Studio. I used all the settings Microsoft has recommended.

I changed my MTU size and firewall to optimize the connection, but yesterday morning everything work without problems but in the evening it just doesn't wanna work anymore. I did a test to make sure the connection was stable and it was completely stable. I have read that these problems are serversided, is there a problem somewhere? I have the same issues with OBS at home when i try to stream to a teams live rtmp.

OBS logs:


08:40:07.271: [x264 encoder: 'advanced_video_stream'] preset: veryfast
08:40:07.271: [x264 encoder: 'advanced_video_stream'] profile: high
08:40:07.271: [x264 encoder: 'advanced_video_stream'] settings:
08:40:07.271: 	rate_control: CBR
08:40:07.271: 	bitrate:      2500
08:40:07.271: 	buffer size:  2500
08:40:07.271: 	crf:          23
08:40:07.271: 	fps_num:      30
08:40:07.271: 	fps_den:      1
08:40:07.271: 	width:        1280
08:40:07.271: 	height:       720
08:40:07.271: 	keyint:       60
08:40:07.273: ---------------------------------
08:40:07.273: [FFmpeg aac encoder: 'adv_stream_aac'] bitrate: 192, channels: 2, channel_layout: stereo
08:40:07.274: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmps://
08:40:07.276: [rtmp stream: 'adv_stream'] Interface: Realtek PCIe GbE Family Controller (ethernet, 1000 mbps)
08:40:08.234: Set FFmpeg options: 
08:40:08.369: [rtmp stream: 'adv_stream'] Connection to rtmps:// successful
08:40:08.370: [rtmp stream: 'adv_stream'] Socket send buffer is 65536 bytes
08:40:09.636: WriteN, RTMP send error 10053 (88 bytes)
08:40:09.636: WriteN, RTMP send error 10053 (42 bytes)
08:40:09.636: WriteN, RTMP send error 10038 (42 bytes)
08:40:09.636: [rtmp stream: 'adv_stream'] Disconnected from rtmps://
08:40:09.637: Output 'adv_stream': stopping
08:40:09.637: Output 'adv_stream': Total frames output: 2
08:40:09.637: Output 'adv_stream': Total drawn frames: 71
08:40:09.637: Output 'adv_stream':  Reconnecting in 5.00 seconds..
08:40:09.684: ==== Streaming Stop ================================================


I have seen a number of people that had this issue with Twitch servers but i can't find a solution for Teams.


Anyone have any idea's?


2 Replies

@ThomasFVNLThe following will sort out if it is/was the Teams Ingest server or your network blocking the RTMP traffic: 

1. From inside your network...Try publishing to an alternate public RTMP service (like YouTube Live or Facebook Live.) If you can push to that service without error, then your network is not the problem. It's the ingest server or the Internet route to get there. 

2. Next, try publishing to the Teams ingest server from another network. Maybee mobile broadband or somewhere outside of the firewall (public IP)


There could be a dozen causes of this type of error. I've seen ISPs black-hole traffic as well as network security services suddenly block traffic even after a successful test session.  The key to troubleshooting is to start with known goods and work through the process to narrow down the cause from a local issue to an array of causes once the traffic gets to the public internet. 

@ThomasFVNL any update on resolution of this issue?  We are facing same in constant disconnects from OBS.  I am wondering if I have the convention wrong for ingest URL and stream key input to OBS.  Back when it was MS Stream based setup you had to enter the entire URL from MS and then the word "live" for stream key.  I figured this would now simply be the stream key MS gives you but its still not connecting and I have tried about every other combination I can think of but no luck ...  I get the disconnect issue from numerous ISPs both internal and external..