Unable to install latest PowerShell Module

Brass Contributor

I'm trying to follow the instructions here: because ultimately I want to run the Get-TeamChannelUser which is only available in these beta modules. It looks like they are at version 1.0.21, but I can't get past version 0.9.6. 


I closed out of all PS sessions (even rebooted), uninstalled the original Teams module and then started trying to install the latest. You can see in the screen shot below I already registered the repository which is why I get that error. 



Now when I get the version of the installed module, it's still 0.9.6 and the Get-TeamChannelUser is not available. 


I've tried to do an Update-Module and even use the -UseMinimumVersion flag but none of that works. What am I missing here?

7 Replies

@michaelkubala ,


The command is available in current version. Can you please try any one of the below steps.

1) clean uninstall and reinstall the microsoftteams module

uninstall: Uninstall-Module -Name MicrosoftTeams


2) update the current version

Update-Module -Name MicrosoftTeams

 Minimum powershell version should be 3.0

@subhasish-MSFT Yeah I've tried uninstalling and reinstalling several times, but it never updates to the latest version. 

@michaelkubala ,
Which cmdlet are you trying for installing MicrosoftTeams module?

Can you please try this. It worked for me.
Install-Module -Name MicrosoftTeams -RequiredVersion 1.0.21

best response confirmed by michaelkubala (Brass Contributor)



Yeah I had tried that command, but it didn't work. I got the issue resolved now though. I noticed that even after running Uninstall-Module, the module was still in my Modules directories on my machine. I manually deleted the MicrosoftTeams module folder in both modules directories and went through the install steps again and now I see that MicrosoftTeams v1.0.21 is installed. 

This is what I get

PS C:\WINDOWS\system32> Install-Module -Name MicrosoftTeams -RequiredVersion 1.0.21
PackageManagement\Install-Package : No match was found for the specified search criteria and module name 'MicrosoftTeams'.

Without -RequiredVersion it does install, but then it's the 1.06 :(



@ValliMarco Thank you!