I can not Create an application instance in my tenant.

Copper Contributor

I want to record calls with bots, I am following this guide




but it does not work

Powershell version: 5.1.19041.1


any ideas?



9 Replies

Hi @AngelicaEnriquez88 ,


My Spanish is shocking but I translate that as it is not seeing that as a valid cmdlet.


So in the first instance we want to ensure that we have the required module. 


So I think that the modules are still split for Teams and the Voice side of Teams. So I would ensure you have done the following first:


Eventually this will be merged into the one module, which I am really looking forward to.




Hi @HenryPhillipsNimbitech 

It doesn't work either, sorry I don't know what happens, I'm new to this.




Thanks so much!

Hi @HenryPhillipsNimbitech 

Thank you, what you gave me helped me.


This works for me:

Import-Module SkypeOnlineConnector
$userCredential = Get-Credential
$sfbSession = New-CSOnlineSession -Credential $userCredential -OverridePowerShellUri "" -Verbose


but I have a other problem, 

I tried whit:

 Enable-PSRemoting, but same error





Any idea? or I need to open a new issue?

Thanks so much in advance!


Hi @AngelicaEnriquez88 ,


That looks like an access denied.

Just to be sure or if you can even. Can you specify your credentials as *


Of course you will need to switch out the * and the tenantname for your username and tenant.

Just to confirm this is what I can do to connect in case it helps:

$session = New-CsOnlineSession

Import-PSSession $session -AllowClobber









Hi @HenryPhillipsNimbitech, Thank you, it was so helpful to me.
However, I still can't create the instance.


I executed:

$session = New-CsOnlineSession

Import-PSSession $session -AllowClobber




I don't know what my mistake

I also tried it with:


During my test, we need below steps to connect to Skype for Business Online:
1. Downloading and installing Windows PowerShell
2. Downloading and installing LyncOnlinePowershell.exe, then open Windows PowerShell with administrator, and run "Import-Module LyncOnlineConnector".
3. Then start to build connection with your Office 365 credential:
$credential = Get-Credential$session = New-CsOnlineSession -Credential $credential -Verbose Import-PSSession $session

I try to run again, but it tells me that it is in use, then I search if there is an instance, it does not bring results either.error3.png


I honestly don't know what to do anymore. I even created a new app in azure, I gave it privileges, I uploaded the certificate, the user I use here is the owner.


best response confirmed by AngelicaEnriquez88 (Copper Contributor)

Hi @AngelicaEnriquez88 ,


Bit worried about the mention of PowerShell 3.0 :)

Try looking to:




The above is basically a version of the Teams PowerShell module that incorporates the two and should remove the need for a separate Lync/Skype Module.

So see if it lets you load this module and create a new-csonline session from there.





Hi @HenryPhillipsNimbitech sorry the powerShell version is 5.1 :D.

Same result and I uninstalled Skype for Business Online Connector






Hi @HenryPhillipsNimbitech 

I could already create the instance

Thanks so much!!!


My instance problem was the name, I changed it and it worked for me.
I used Teams PowerShell module as you suggested.

thanks, again!!