SOLVED

Error while reading manifest.json: Invalid value(s) specified for validDomains[0]

Occasional Contributor

While developing an application for MS Teams, I am using ngrok for exposing localhost URL to HTTPS. Till today it was working, but from today morning I am getting this issue of the invalid domain as below.

 

Error while reading manifest.json: Invalid value(s) specified for validDomains[0]: "https://e9d21d77e3f6.ngrok.io"

 

It is a warning but not able to install the app in MS Teams. Is there any changes made by Microsoft?

24 Replies

@Kaushal Khamar 

Exactly the same thing. Yesterday everything worked well and I could Install the custom application with domains, but today I receive the same error :\

rror while reading manifest.json: Invalid value(s) specified for validDomains[0]: "https://xx.xxx.xx"
Invalid value(s) specified for validDomains[1]: "https://xx.xxx.xx"
Invalid value(s) specified for validDomains[2]: "https://xx.xx.xx"

 

Very strange behaviour.

@Mart Lehtmets 

I am not able to install any app in Teams. Must be Microsoft has done something wrong.

@Kaushal Khamar I have same behaviour, same error here. I'am not able to instlall any custom app manifest.

@Kaushal Khamar Same issue here. A few days ago it was working fine. Now we can no longer deploy our custom Teams application using the ngrok domains like. 

 

 

 

"validDomains": [
  "https://xxxx.ngrok.io"
]

 

 

We have tried to omit the "https", but that does not work either.

 

 

"validDomains": [
  "xxxx.ngrok.io"
]

 

 

 Hopefully Microsoft will fix this issue soon.

@Kaushal Khamar  Yesterday it was working fine. Facing same issue. 

Is anyone got it resolved or still facing ? 
Should we need to create app again ?

@bilal_khan 

Wow...seems that Teams developers have released some buggy version out. Hope they address this issue asap.

@bilal_khan 

 

No, Not any resolution. No one is able to install the app in MSTeams. I have tested in multiple systems with multiple tenants. Seems issue with Microsoft Teams.

@Kaushal Khamar I got it working by manually removing the https domain from the validDomains list, and uploading the updated zipfile

 

@martinlingstuyl Indeed, it works. Thanks a lot. But it only works when you upload the zip file using "Upload custom app" instead of importing it via the App Studio.

The App Studio always adds the leading HTTPS based on the URLs that are used in Tabs e.g. Even if you upload a custom manifest, App Studio would add the leading HTTPS, resulting in an invalid manifest again.

"validDomains": [
  "https://xxxx.ngrok.io",
  "xxxx.ngrok.io"
]

 

@martinlingstuyl 

 

I have tried the same thing but not worked for me.

 

After removing https manually and uploading the manifest file, it automatically adding URL from the content URL with HTTPS. 

 

Capture.PNG

 

@Kaushal Khamar See @Adrian42's reply. This is exactly the behavior I see. So If you go to Apps and then select 'Upload a custom app', it will work.

@martinlingstuyl 

Waiting for any Microsoft person to look into this issue.

@Kaushal Khamar 

 

Also having this issue. First time learning to create an app for Teams and this happens... :facepalm:

Me too, but at least I did not have to sit on my hands.

@Kaushal Khamar with the free version of ngrok, the xxxxxxxx.ngrok.io links expire after 8 hours, so that's your problem. If you don't want to keep updating your URLs, you might want to purchase the basic version which gives you custom subdomains that don't expire.

Hi @Bill Bliss  There is no issue of ngrok. ngrok URL is generated just 5 minutes before. Even i am using my private domain url is not working.