add-app-dialog-v3-add-button: App sideloaded for personal scope failed [object Object]

Copper Contributor



I am a just beginner of Teams app developing. 

I just followed this exactly same step..


I clicked "Add" button..then it shows "Something went wrong".... I looked at the console of Visual Studio Code...


App sideloaded for personal scope failed [object Object]
{message: '', status: 400, errorCode: 'CreateUserAppDefinitionFailed'} undefined
arg0:{message: '', status: 400, errorCode: 'CreateUserAppDefinitionFailed'..
I researched a bit..but I couldn't find thing I found was that someone mentioned that could be manifest error..but I haven't changed it...All I did was just try to distribute to see how it is going to work..
When I just invoked in the browse, "https://localhost:3000/tab",  I see this default message..
" Hello World! Congratulations ! This is the tab you made :-)"


Any clues? What should I do to add this "Hello World" so I can see this actually in the MS Team then?



7 Replies
Hi @firstteam, could you please try uninstall and install the app from you app studio.
What do you mean?. You mean uninstall Microsoft Team Toolkit and install it again? Ok.. I did..but still same thing.
Or you mean "Install" Button in the App Studio..Actually, I didn't install this one..because when I clicked "Install" button, nothing happened...seems like didn't do any I did F5(start debugging) from the visual studio code to test....Once I did that...I see that "Add" button on the pop window..then clicked it..then I saw "Something went wrong"..
Ok.. never mind about this issue. Somehow it started working...I saw my HelloWorld in the Team app. However, the strange thing is that......Here is what is happening... I was able to test...then I closed my Visual Studio Code...then opened the same Hello World workspace...then I tried to test it says that "App not found, Please verify the app and it's access permissions."... there something I would need to do every time before I start debugging? What is it then? Now why am I seeing this message, "App not found, Please verify the app and it's access permissions." ???
Now I just tried this.. I see this message..

"App not found, Please verify the app and it's access permissions."

BTW, I realized this development environment is so acting strangely. I have no idea what causes this.. I looked at the browser console.. Get 404..

It looks like somehow my manifest hasn't been uploaded to the server??..then why is that? Is there anything I would need to do other than clicking "start debugging"? BTW, still,
Install button under Test and distribute in App Studio ... doing didn't respond any when I clicked "Install" button.. so only way I could see the action is by "Start Debugging" from Visual Studio Code......

Ok..I think I figured this out. I think I MUST download, and then upload that zip in order to start testing. HOWEVER, this is VERY inconvenient. Is there any way I could upload it automatically somehow by pressing F5(Start debugging)???? ..BTW, also my ultimate question again is that why "Install" button is doing nothing?????????
Hi @firstteam, we are unable to repro your issue from our end.