Surface Pro 3 re-image through USB

Copper Contributor

Hello, everyone! Hope everyone is well.


Guys, have anyone faced this? We have Surface Pro 3 here, we followed the steps described in:


  • Downloaded the Image for Surface Pro 3 (inserted model and serial number)
  • Downloaded the zip file
  • Prepared USB using Recovery Drive
  • Unchecked Back up system files to the recovery drive
  • Once created, extracted all zip file content to the drive
  • Also tried using CMD > diskpart > select disk and clean/create partition primary
  • Set Surface Pro 3 BIOS to TPM and Secure Boot to Disabled (also tried enabling)

These steps just results in a Black screen after booting the USB. Right after the "Surface" loading screen with circling dots.


Does anyone have any ideas? Is this maybe a hardware issue?

6 Replies
Did you try to enter Surface Pro UEFI setting(also named BIOS) ?
if it can, mostly show that the hardware is OK.
for Pro 4, to enter BIOS, press "Volume +" and Power keys in the same time,
I think Pro 3 should be same with Pro 4
Good luck
Ah, yeah. Unfortunately I tried and tried also tweaking some settings there. Turning off Secure Boot (Surface screen goes red), boot order, TPM, it always seems to boot the USB and screen goes black (it keeps the screen on tho, so I know the device doesn't turn off)


so, the hardware seems OK and the problem might be USB disk can not  boot

Please  follow this link:

1. download the  win10 iso file.

2. use Media Creation tool to create a USB installation disk.

However, I did not try this tool because I use other tool to create USB installation disk,


Hope this help*ivFEQ&ranSite...



Thanks for your suggestion. Just tried it once again using Microsoft's Media creation tool. I created a Win10 (both x86/x64 build) but once booted the screen gets stuck in this step. The circling bullets, they just keep circling, without any progress. Any ideas?IMG_0116.jpg



This perhaps can be hardware problem, in most cases I guess, SSD problem.
It need to open the screen by hot gun / hair drier to check hardware inside
Be careful, it's easy to damage the screen
Good Luck

Ugh, yeah, I was thinking it might be a hardware problem, since we've been strugling with it and nothing was working. Thanks for the help!