SOLVED

Workflow notification Email issue

%3CLINGO-SUB%20id%3D%22lingo-sub-680738%22%20slang%3D%22en-US%22%3EWorkflow%20notification%20Email%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-680738%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20All%2C%3C%2FP%3E%3CP%3EWe%20were%20built%20email%20notification%20using%20window%20workflow%20foundation%20on%20sharepoint%202010%20and%20migrated%20to%20sharepoint%202013.%20it%20was%20working%20fine%20on%20SharePoint%202010.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20migration%20we%20started%20getting%20broken%20image%20issue%26nbsp%3B%20before%2F%20after%20the%20person%20name%20in%20the%20email.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEmail%20body%20code%20is%26nbsp%3B%20highlighted.%3C%2FP%3E%3CP%3EworkflowProperties.Item.%3CSTRONG%3EGetFormattedValue(%22Modified%20By%22).ToString()%3C%2FSTRONG%3E%20%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EBroken%20image%20pics%26nbsp%3B%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20573px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F117632i90971FE905EB54BE%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Email.png%22%20title%3D%22Email.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EPlease%20suggest%20what%20need%20to%20be%20changed%20in%20the%20code%20to%20make%20or%20remove%20image%20tag%20from%20email.%3C%2FP%3E%3CP%3EThanks%20!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-680738%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2013%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-684906%22%20slang%3D%22en-US%22%3ERe%3A%20Workflow%20notification%20Email%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-684906%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F18519%22%20target%3D%22_blank%22%3E%40Kamal%20Pandey%3C%2FA%3E%26nbsp%3BI%20think%20the%20code%20is%20returning%20the%20formatted%20value%20as%20the%20Name%20with%20(Skype%20for%20Business%20or%20Lync)%20presence.%20So%20from%20that%20list%2C%20in%20the%20column%20properties%2C%20change%20the%20%22Show%20field%3A%22%20value%20from%20%22Name%20(with%20Presence)%20to%20the%20first%20%22Title%22%20value%20in%20the%20drop%20down.%20I%20don't%20think%20you%20will%20need%20to%20recompile%20the%20workflow%2C%20but%20I%20think%20that%20might%20be%20what's%20causing%20the%20extra%20broken%20images%20there.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-687737%22%20slang%3D%22en-US%22%3ERe%3A%20Workflow%20notification%20Email%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-687737%22%20slang%3D%22en-US%22%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F228093%22%20target%3D%22_blank%22%3E%40Timothy%20Balk%3C%2FA%3E%2C%20Thank%20you%20so%20much%20for%20response%2C%20I%20really%20appreciate%20it.%20I%20have%20updated%20Name%20(with%20Presence)%20to%20the%20just%20Name%20because%20i%20don't%20have%20%22Title%22%20value%20in%20the%20drop%20down%2C%20and%20now%20we%20getting%20one%20broken%20image.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-687921%22%20slang%3D%22en-US%22%3ERe%3A%20Workflow%20notification%20Email%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-687921%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F72901%22%20target%3D%22_blank%22%3E%40Kamal%20Pandey%3C%2FA%3E%26nbsp%3BOk%2C%20last%20thing%20to%20try%20-%20the%20last%20image%20may%20have%20a%20CSS%20class%20on%20it%20labeled%20%22ms-hide%22%20add%20the%20class%20into%20the%20email%20CSS%20and%20that%20might%20take%20care%20of%20the%20last%20image.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E.ms-hide%20%7Bdisplay%3Anone%3B%7D%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-690466%22%20slang%3D%22en-US%22%3ERe%3A%20Workflow%20notification%20Email%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-690466%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you%20so%20much%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F228093%22%20target%3D%22_blank%22%3E%40Timothy%20Balk%3C%2FA%3E%20.%26nbsp%3B%20appreciated.%3C%2FP%3E%3CP%3Estring%20stylehide%20%3D%20%22%3CSTYLE%3E.ms-imnlink%20%7Bdisplay%3Anone%3B%7D%20.ms-hide%20%7Bdisplay%3Anone%3B%7D%3C%2FSTYLE%3E%22%3B%26nbsp%3B%3C%2FP%3E%3CP%3Eworks%20for%20me%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hello All,

We were built email notification using window workflow foundation on sharepoint 2010 and migrated to sharepoint 2013. it was working fine on SharePoint 2010.

 

After migration we started getting broken image issue  before/ after the person name in the email.

 

Email body code is  highlighted.

workflowProperties.Item.GetFormattedValue("Modified By").ToString()  

    

 

Broken image pics 

Email.png

Please suggest what need to be changed in the code to make or remove image tag from email.

Thanks !

4 Replies

@Kamal Pandey I think the code is returning the formatted value as the Name with (Skype for Business or Lync) presence. So from that list, in the column properties, change the "Show field:" value from "Name (with Presence) to the first "Title" value in the drop down. I don't think you will need to recompile the workflow, but I think that might be what's causing the extra broken images there.

@Timothy Balk, Thank you so much for response, I really appreciate it. I have updated Name (with Presence) to the just Name because i don't have "Title" value in the drop down, and now we getting one broken image.
best response confirmed by Kamal Pandey (Contributor)
Solution

@Kamal Pandey Ok, last thing to try - the last image may have a CSS class on it labeled "ms-hide" add the class into the email CSS and that might take care of the last image.

 

.ms-hide {display:none;}

Thank you so much @Timothy Balk .  appreciated.

string stylehide = "<style>.ms-imnlink {display:none;} .ms-hide {display:none;}</style>"; 

works for me