Version History broken in modern SharePoint "Sorry, something went wrong"


Hi all - 


We are operating in SharePoint Online, using modern libraries. Versioning is turned on, but every time we click to check the version history on a documents, we are greeted with, "Sorry, something went wrong", and no usable details provided. 


Any ideas what is going on? It's a little scary not being able to access previous versions of our files. 



20 Replies
I have just verified on one of my tenants that versioning is working as expected so it could be a problem of your tenant....have you tried to see the version of a document on another browser / PC

Versioning is failing even with alternate browsers and computers. I even tried it on my home computer and got the same message. I double-checked that versioning is turned on in our libraries. 


Here's the funny thing - It works on our old classic sites, just not our modern sites. I have no idea how to troubleshoot this. 



This may sound a little basic but try clearing the browser history. Beyond that you should reach out to Microsoft Support.

Dose the version works if you temporary switch back to the classic experience?

Sounds like I'm going to have to open a ticket with Microsoft. Clearing the browser history didn't help, nor did switching back to the classic version of the library. Weird!

Did you switch back to classic view on your document libraries and tried it?

Yep, tried that too, and keep getting the same vague error.

I'm experiencing the exact same error. Was Support able to resolve?

Turns out to be a little complicated. The library in question was created via a migration of an existing classic library using Sharegate. When the library migrated over, it omitted the default forms (apparently they were custom) - Edit.aspx, New.aspx, etc. 


I was told to use SharePoint Designer to simply add these forms to the new modern library, but SPD won't let me do that on modern libraries (it throws an error), and apparently this task is not possible using SharePoint Online. 


So end result is that I have to re-migrate all these libraries using brand-new-created-by-hand libraries, which I am not looking forward to. But the core issue is those missing default forms. 

We are experiencing the same problem after a ShareGate migration.. 
Did you solve the problem? If yes, how?

After weeks of research and troubleshooting, I just had to rebuild and remigrate my libraries. Supposedly it had something to do with the way my libraries were originally set up, but to this day I've never been able to pinpoint what that issue was. I am not the one who built the original libraries, so I don't know what weird nuance threw everything off. 


I do know that attempts to add form types to the new libraries failed in SharePoint Designer, and this was the #1 resolution that people sent my way. 

best response confirmed by Caite Stevens (Contributor)

I’m with Caite on this one, I ended up having to re-migrate the content while deliberately making sure absolutely nothing else was migrated beyond the files and their versions. No customized forms/views, no required features, etc.

@Caite Stevens 

We are experiencing the same issue with a ShareGate migrated library.

We used a workaround to access the document history by opening the file in Word and restoring the old version from there.





@Caite Stevens 

if you were to run into this issue. Or wanting to make sure the forms are not "custom" but the true out of the box check this script 

(currently just for lists but can easily be adjusted for libraries as well)



@Asia Gandecka 


Anyone confirms if this is resolved? any workaround?


I believe Solution is to re-create your library and upload data there.




I resolve this issue by reset the DispForm.aspx page using SharePoint Designer.

- Open SharePoint Designer go to lyour site

- Click Lists and Libraries

- Click on your list or library

- on the right side, under forms, click New to create new DispForm.aspx and set at default

           you might have to rename this page or just rename the old DispForm.apsx for this to work

           * rename by Click All Files on the left, then click your library, click Forms, the rename the file

- That's all this should restore your view history 


Sorry for replying to the old post, but it seems to be the only workaround other than re-migrate with ShareGate. As SharePoint Designer doesn't work with SharePoint Online modern site, is your SharePoint site a classic one on-premise?

@Peter2wxinWhen I experienced the issue, it was modern online SharePoint.

@Caite Stevens 


I managed to get my migrated libraries version history working again.


My library is called "ORMS" and the version history was broken after we migrated using ShareGate


Here is what i did to fix it...

  1. In the migrated (new) library get the List ID
    You can find this in site settings --> Site libraries and lists --> ORMS (The list ID will be in the URL)
  2. In SharePoint designer open the new site and navigate to the dispForm.aspx. In my case it is:
    All Files/ORMS/Forms/DispForm.aspx
  3. Edit the file in advanced mode (make a copy before editing to be safe)
  4. In the code, find and replace the ListIDs within the following 2 tags with the list id you copied earlier:
  5. Save and close
  6. Return to your library and check the Version history

This worked for me so i am interested to hear if it works for others.