Unable to add a script editor web part to my "Discussion board" AllItems.aspx page

Valued Contributor

Hi all

using the global admin username i created a new communication modern site , and i migrated the content of an on-premises site collection to it. now by defualt the the communication site will have "custom script" disabled. so i run the following command to enable custom scripting:-

 

Connect-SPOService -Url https://tenant-admin.sharepoint.com

Set-SPOSite -Identity https://tenant.sharepoint.com/sites/contoso -DenyAddAndCustomizePages 0

 

then i checked the status for the cusotm script and i can see that it is enabled as follow:-

 

$Url = "https://tenant.sharepoint.com/sites/contoso"
Get-SPOSite -Identity $Url -Detailed | select DenyAddAndCustomizePages

DenyAddAndCustomizePages
------------------------
Disabled

 

 

but when i edit my AllItems.aspx page for our discussion board list,i was not able to add a script editor web part:-

webpart123.png

 

although since i have enabled custom script for the communication modern site, i should be able to add a script editor,, is this correct?

also if i edit a classic page , i can add a script editor web aprt to it as follow:-

two123.png

 

2 Replies
I think you need to enable a feature at the site collection level that populates missing WebParts in the site

@Juan Carlos González Martín wrote:
I think you need to enable a feature at the site collection level that populates missing WebParts in the site

can you adivce or do you know which site features i should enable?