SharePoint returning HTTP Status code 500 when posting files like png,pdf etc..

%3CLINGO-SUB%20id%3D%22lingo-sub-1580190%22%20slang%3D%22en-US%22%3ESharePoint%20returning%20HTTP%20Status%20code%20500%20when%20posting%20files%20like%20png%2Cpdf%20etc..%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1580190%22%20slang%3D%22en-US%22%3E%3CP%20class%3D%22%22%3EHi%20Experts%2C%3C%2FP%3E%3CP%3ESharePoint%20returning%20HTTP%20Status%20code%20500%20when%20posting%20files%20like%20png%2Cpdf%20etc.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EResponse%20body%20from%20SharePoint%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CERROR%20m%3D%22%26quot%3B%26lt%3BA%22%20href%3D%22http%3A%2F%2Fschemas.microsoft.com%2Fado%2F2007%2F08%2Fdataservices%2Fmetadata%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%22%3E%3CA%20href%3D%22http%3A%2F%2Fschemas.microsoft.com%2Fado%2F2007%2F08%2Fdataservices%2Fmetadata%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttp%3A%2F%2Fschemas.microsoft.com%2Fado%2F2007%2F08%2Fdataservices%2Fmetadata%3C%2FA%3E%22%26gt%3B%3CBR%20%2F%3E%3CCODE%3E-1%2C%20System.IO.IOException%3C%2FCODE%3E%3CBR%20%2F%3E%3CMESSAGE%20lang%3D%22%26quot%3Ben-US%26quot%3B%22%3EI%2FO%20error%20occurred.%3C%2FMESSAGE%3E%3C%2FERROR%3E%3C%2FP%3E%3CP%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CP%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20you%20please%20help%20me%20with%20this.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EPlease%20find%20the%20screenshot%20attached.%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3EI%20am%20hitting%20sharepoint%20URL%20through%20SAP%20Cloud%20Platform%20Integration%20middleware.%3C%2FP%3E%3CP%3EI%20am%20able%20to%20read%20file%20from%20Sharepoint%20in%20binary%20format%20and%20constuct%20original%20file%20but%20when%20i%20try%20to%20post%2Fupload%20file%20to%20Sharepoint%20i%20am%20getting%20below%20error.%26nbsp%3B%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22SharePoint.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F211719i5793BE8AB903EBEE%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22SharePoint.png%22%20alt%3D%22SharePoint.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20you%20please%20help%20me%20if%20SharePoint%20expects%20any%20header%20other%20than%20Authorization%20while%20accepting%20binary%20files%20as%20i%20am%20able%20to%20post%20text%20files%20without%20any%20issue%20in%20code.%3C%2FP%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1580190%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFiles%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Regular Visitor

Hi Experts,

SharePoint returning HTTP Status code 500 when posting files like png,pdf etc.

 

Response body from SharePoint

 

<?xml version="1.0" encoding="utf-8"?>
<m:error xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata">
<m:code>-1, System.IO.IOException</m:code>
<m:message xml:lang="en-US">I/O error occurred.</m:message>

</m:error>

 

Could you please help me with this.

 

Please find the screenshot attached.

I am hitting sharepoint URL through SAP Cloud Platform Integration middleware.

I am able to read file from Sharepoint in binary format and constuct original file but when i try to post/upload file to Sharepoint i am getting below error. 

 
 

SharePoint.png

 

Can you please help me if SharePoint expects any header other than Authorization while accepting binary files as i am able to post text files without any issue in code.

0 Replies