SharePoint online term store (managed meta data service) error, on term move or delete with Chrome

Frequent Contributor

Hi Everyone,


Problem : When I try to delete or move a term in our SharePoint online term store (managed meta data service) I get an error "An unexpected error has occured. Please try again later"


Tried : closing browser and logging in again, deleting cookies for sharepoint admin site.


What worked : Use internet explorer instead of Chrome !!!!

What the hey hey!

Come on guys - this is a really old bug you've got back.


I'm posting this for three reasons:

- vent some frustration

- I couldn't find anything about this error or it's cause

- I home MS take a look and know about it and fix this issue.



4 Replies

@Dorje McKinnon 


Just ran in to this same issue this morning. Glad to hear you figured out a fix. 


Funny thing is, I'm using the new Chromium Edge browser. I'll give IE a shot.


Edit: No go on IE either. Dang. Wonder if any additional SharePoint admin permissions options where added to the O365/Azure Admin Security Roles.

best response confirmed by Dorje McKinnon (Frequent Contributor)

Hi @braddn 

I just tested again today moving a term from one node to another:

- Chrome 84.0.4147.135 (Official Build) (64-bit) gave me the error

- Internet Explorer11 version 11.1297.17763.0 update version11.0.205  did not give me the error


I thought I was using the same user account in both browsers.

BUT after checking I was using different accounts in each of the browsers (I have a normal and an admin account)

- Chrome was my admin account

     - Admin account is NOT a term store admin

- IE was my normal account

     - Normal account Is a term store admin


When I added my admin account to be a term store admin I am able to move the term and NOT get the error.


Conclusion :

Firstly, I apologize to the Microsoft team for assuming that the issue was one of browser incompatibility.

Secondly, MIcrosoft new Managed Metadata User interface team : display useful error messages AND / OR don't show my account controls I don't have the rights to use.


Finally, @braddn  I think if you get your user added as a Term Store admin, you'll not see this error :)

@Dorje McKinnon thanks for posting this question, I had the same issue today and didn't immediately think it was a permissions problem thanks to the lack of a descriptive error message! I'm a SharePoint admin, but got this error trying to add a term set. Added myself as a term store admin and boom it works.