SOLVED

SharePoint Navigation Sub Headings

%3CLINGO-SUB%20id%3D%22lingo-sub-2735641%22%20slang%3D%22en-US%22%3ESharePoint%20Navigation%20Sub%20Headings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2735641%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOur%20site%20contains%20headings%20and%20subheadings%20on%20the%20navigation%20menu%3A%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Christina_Thomas369_3-1631180739191.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F309203i0592648ABA8FE052%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Christina_Thomas369_3-1631180739191.png%22%20alt%3D%22Christina_Thomas369_3-1631180739191.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20now%20no%20longer%20able%20to%20edit%2C%20remove%20or%20add%20new%20links%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Christina_Thomas369_2-1631180706058.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F309202iB471876D0733439D%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Christina_Thomas369_2-1631180706058.png%22%20alt%3D%22Christina_Thomas369_2-1631180706058.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20asked%20IT%20to%20check%20just%20in%20case%20it%20is%20a%20permissions%20issue%20and%20they%20have%20the%20same%20issue.%20Has%20anyone%20else%20experienced%20this%20or%20could%20advise%20why%20this%20might%20be%20happening%20and%20how%20I%20can%20resolve%20it%20please%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2735641%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2736548%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Navigation%20Sub%20Headings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2736548%22%20slang%3D%22en-US%22%3E%3CP%3EHey%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1150872%22%20target%3D%22_blank%22%3E%40Christina_Thomas369%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EDo%20you%20know%20what%20kind%20of%20site%20this%20is%3F%20It%20looks%20like%20a%20Modern%20Team%20Site%20but%20can%20you%20confirm%3F%20I%20ask%20because%20we%20have%20seen%20updates%20in%20Modern%20to%20how%20we%20update%20the%20links%2C%20e.g.%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22DavidFrancoeur_0-1631198326479.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F309278i3ECF52957D84F616%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22DavidFrancoeur_0-1631198326479.png%22%20alt%3D%22DavidFrancoeur_0-1631198326479.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2737438%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Navigation%20Sub%20Headings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2737438%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F293102%22%20target%3D%22_blank%22%3E%40DavidFrancoeur%3C%2FA%3E%26nbsp%3BIt%20is%20indeed%20David%20thank%20you%2C%20I%20should%20have%20put%20that%20in%20my%20original%20post%20sorry!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2738209%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Navigation%20Sub%20Headings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2738209%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1150872%22%20target%3D%22_blank%22%3E%40Christina_Thomas369%3C%2FA%3E%26nbsp%3BCan%20you%20confirm%20you%20cannot%20edit%20the%20links%20from%20the%20front-end%20(via%20the%20page)%20by%20clicking%20edit%20here%3F%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22DavidFrancoeur_0-1631222087370.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F309450iBAD0F04B7B8F9B8D%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22DavidFrancoeur_0-1631222087370.png%22%20alt%3D%22DavidFrancoeur_0-1631222087370.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi

 

Our site contains headings and subheadings on the navigation menu: 

Christina_Thomas369_3-1631180739191.png

 

I am now no longer able to edit, remove or add new links:

Christina_Thomas369_2-1631180706058.png

 

I have asked IT to check just in case it is a permissions issue and they have the same issue. Has anyone else experienced this or could advise why this might be happening and how I can resolve it please?

 

Thank you!

 

8 Replies

Hey @Christina_Thomas369 

Do you know what kind of site this is? It looks like a Modern Team Site but can you confirm? I ask because we have seen updates in Modern to how we update the links, e.g.:

DavidFrancoeur_0-1631198326479.png

 

@DavidFrancoeur It is indeed David thank you, I should have put that in my original post sorry!

@Christina_Thomas369 Can you confirm you cannot edit the links from the front-end (via the page) by clicking edit here?

DavidFrancoeur_0-1631222087370.png

 

Correct, I can edit all main links but the sub links do not appear.

@Christina_Thomas369 Any chance you can share a screenshot of this view, both in Edit mode and in the View mode (published page).

 @DavidFrancoeur Of course:

 

Christina_Thomas369_0-1631711082052.png

 

Christina_Thomas369_2-1631711142103.png

 

Christina_Thomas369_3-1631711168858.png

Thank you for your continued support

 

Christina

 

best response confirmed by Christina_Thomas369 (Occasional Contributor)
Solution

@Christina_Thomas369 Thanks
I see what's going on, you likely have the Site Collection Publishing Feature enabled which is why it's shooting you to the old classic way to manage the links. Even with this, though, I can't replicate the issue. Are you in SharePoint Online? It could be your tenant is seeing the effects of some changes in this area. While I cannot confirm for sure, I would move away from this way of managing links except in cases of Classic Sites as you are going to lose out on new functionality (e.g., improved link translation just rolled out). 

 

While it's not a recommendation I can make without an assessment (e.g., is there any data that is dependent on the Publishing Feature), disabling this SC feature should allow the navigation to revert to the modern experience:

DavidFrancoeur_1-1631802367073.png

Thank you very much David, this would make perfect sense and I've always had a feeling of classic look when I've been in this area. I'll ask IT to look into this feature.