SharePoint modern list view not displaying items

%3CLINGO-SUB%20id%3D%22lingo-sub-205627%22%20slang%3D%22en-US%22%3ESharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-205627%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20hope%20you%20can%20help%20me.%3C%2FP%3E%3CP%3EI%20have%20a%20SharePoint%20site%20with%20multiple%20lists%2C%20which%20are%20all%20using%20the%20Modern%20list%20view.%3C%2FP%3E%3CP%3EA%20few%20days%20ago%20one%20of%20the%20modern%20list%20views%20aren't%20displaying%20items%2C%20even%20though%20there%20are%20more%20then%2060%20items%20in%20the%20list.%20If%20I%20switch%20to%20classic%20view%20all%20my%20items%20are%20displayed%20in%20the%20view.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBest%3C%2FP%3E%3CP%3EThomas%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20793px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F36247i61BDE6F32A1FAB34%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Microsoft_Error_SharePoint_List_Modern_View_No_Items_01.png%22%20title%3D%22Microsoft_Error_SharePoint_List_Modern_View_No_Items_01.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F36248i40DC3A4FFAD50AA5%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Microsoft_Error_SharePoint_List_Modern_View_No_Items_02.png%22%20title%3D%22Microsoft_Error_SharePoint_List_Modern_View_No_Items_02.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F36249iF668D54B9BA912B5%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Microsoft_Error_SharePoint_List_Modern_View_No_Items_03.png%22%20title%3D%22Microsoft_Error_SharePoint_List_Modern_View_No_Items_03.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-205627%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-339858%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-339858%22%20slang%3D%22en-US%22%3E%3CP%3EI%20wish%20it%20was%20that.%20there%20was%20no%20issue%20with%20the%20JSON%20it%20worked%20for%20a%20good%20week%20then%20this%20issue.%20Microsoft%20basically%20said%20the%20list%20got%20corrupt%20some%20how%2C%20didn't%20have%20anything%20to%20do%20with%20JSON.%20once%20i%20change%20required%20to%20not%20required%20and%20back%20it%20work.%20JSON%20was%20never%20changed.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-339834%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-339834%22%20slang%3D%22en-US%22%3EThe%20reason%20for%20this%20is%20because%20there%20is%20a%20JSON%20programming%20within%20a%20list%20column%20that%20is%20no%20coded%20correctly.%20This%20is%20the%20way%20of%20the%20system%20saying%20that%20there%20is%20an%20error%20in%20the%20JSON%20formula.%20To%20fix%20the%20issue%2C%20go%20to%20the%20column%20settings%20for%20the%20column%20that%20has%20JSON%20formatting%20and%20review%20the%20formula%20or%20erase%20it.%20Once%20the%20formula%20is%20correct%20or%20erased%2C%20it%20will%20show%20the%20list%20in%20the%20modern%20view.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-339833%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-339833%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20reason%20for%20this%20is%20becuase%20there%20is%20a%20JSON%20programming%20within%20a%20list%20column%20that%20is%20no%20coded%20correctly.%20This%20is%20the%20way%20of%20the%20system%20saying%20that%20there%20is%20an%20error%20in%20the%20JSON%20formula.%20To%20fix%20the%20issue%2C%20go%20to%20the%20column%20settings%20for%20the%20column%20that%20has%20JSON%20formatting%20and%20review%20the%20formula%20or%20erase%20it.%20Once%20the%20formula%20is%20correct%20or%20erased%2C%20it%20will%20show%20the%20list%20in%20the%20modern%20view.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-282284%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-282284%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20having%20the%20same%20issue.%26nbsp%3B%20My%20list%20will%20not%20toggle%20back%20to%20%22new%20experience%22.%26nbsp%3B%20I%20tried%20making%20a%20random%20required%20field%20not%20required%2C%20then%20required%20again%2C%20but%20that%20didn't%20change%20anything.%20This%20list%20has%20shown%20in%20modern%20view%20before.%26nbsp%3B%20This%20is%20a%20new%20development.%26nbsp%3B%20It%20occurred%20when%20I%20was%20testing%20ideas%20for%20color%20coding%20columns%20using%20JSON%20script%20which%20requires%20modern%20view.%26nbsp%3B%20A%20test%20list%20worked.%26nbsp%3B%20When%20I%20tried%20it%20on%20this%20list%2C%20I%20could%20not%20get%20the%20modern%20view%20to%20display.%20I%20removed%20the%20test%20column%20with%20the%20JSON%20and%20the%20list%20will%20still%20not%20display%20in%20modern%20view.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-265009%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-265009%22%20slang%3D%22en-US%22%3E%3CP%3EThey%20told%20me%20the%20field%20but%20said%20it%20didn't%20have%20anything%20to%20do%20with%20it%2C%20here%20is%20their%20response.%20Note%20list%20was%20not%20migrated%20but%20it%20still%20worked%20to%20fix%20the%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3EWas%20that%20list%20migrated%3F%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3EIs%20yes%2C%20then%20sometimes%20the%20list%20schema%20gets%20corrupted%20and%20then%20toggling%20certain%20settings%20fixes%20the%20issue.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3ESo%2C%20in%20your%20case%20schema%20might%20have%20been%20corrupted%20due%20to%20some%20reason%20and%20just%20by%20toggling%20the%20setting%20fixed%20it.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20GA%20in%20out%20O365%20tenant%20so%20just%20opened%20in%20there.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-265005%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-265005%22%20slang%3D%22en-US%22%3E%3CP%3EDid%20they%20let%20you%20know%20which%20field%20it%20was%3F%20How%20did%20you%20open%20the%20ticket%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-264976%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-264976%22%20slang%3D%22en-US%22%3E%3CP%3EI%20put%20in%20a%20ticket%20with%20Microsoft%20and%20they%20had%20to%20take%20a%20field%20that%20was%20required%2C%20change%20it%20to%20not%20required%20and%20then%20back%20and%20that%20worked.%20they%20couldn't%20really%20give%20me%20a%20why%20but%20it%20worked.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-264442%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-264442%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20having%20the%20same%20experience.%20So%20frustrating%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-252065%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-252065%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Alexandra%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%2C%20we%20sadly%20didn't%20find%20an%20answer%20to%20this%20issue.%3C%2FP%3E%3CP%3EThe%20solution%20has%20been%20abandoned%20in%20favor%20of%20a%20newer%20version.%3C%2FP%3E%3CP%3EIf%20you%20are%20experiencing%20the%20same%20issue%2C%20I%20hope%20you%20find%20a%20solution.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-251934%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-251934%22%20slang%3D%22en-US%22%3EWhere%20you%20able%20to%20find%20answers%20to%20this%20issue%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-222086%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-222086%22%20slang%3D%22en-US%22%3EHei%20Thomas.%20If%20you%20create%20a%20modern%20page%2C%20and%20add%20the%20Document%20Library%20(preview)%20web%20part.%20Are%20you%20having%20issues%20with%20the%20web%20part%20not%20'remembering'%20what%20view%20it%20should%20use%2C%20and%20falling%20back%20to%20the%20default%20view%3F%20We%20have%20this%20issue%20as%20well.%20Might%20be%20related.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-221924%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-221924%22%20slang%3D%22en-US%22%3E%3CP%3ESadly%20no%2C%20the%20problem%20persists%20in%20the%20%22modern%22%20layout.%3C%2FP%3E%3CP%3EWhere%20using%20the%20%22old%22%20SharePoint%202013%20layout%2C%20and%20here%20there's%20no%20problem.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-221774%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-221774%22%20slang%3D%22en-US%22%3E%3CP%3EI%20started%20having%20this%20issue%20today.%20Any%20luck%20fixing%20it%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-206002%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-206002%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20SPO%20Admin%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tried%20to%20edit%20the%20current%20view%2C%20and%20have%20even%20created%20a%20new%20view%20to%20see%20if%20this%20would%20help%2C%20which%20it%20hasn't...%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F36335iC6F35EEA1E632302%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Microsoft_Error_SharePoint_List_Modern_View_No_Items_04.png%22%20title%3D%22Microsoft_Error_SharePoint_List_Modern_View_No_Items_04.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-206000%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-206000%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Juan%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%2C%20I%20haven't%20opened%20a%20support%20case%20yet%2C%20but%20that%20might%20be%20the%20solution.%3C%2FP%3E%3CP%3EThanks%20for%20your%20reply.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-205767%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-205767%22%20slang%3D%22en-US%22%3E%3CP%3EHave%20you%20tried%20to%20edit%20the%20current%20view%20for%20columns%20and%20see%20if%20it%20displays%20any%20list%20items.%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2Fedit-a-list-view-in-sharepoint-online-15916903-e79a-423f-b4e2-02d37e1ff372%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2Fedit-a-list-view-in-sharepoint-online-15916903-e79a-423f-b4e2-02d37e1ff372%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-205694%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-205694%22%20slang%3D%22en-US%22%3EThis%20is%20very%20weird...have%20you%20opened%20a%20support%20case%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-871964%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-871964%22%20slang%3D%22en-US%22%3E%3CP%3EHas%20any%20solution%20or%20explanation%20been%20found%3F%20I%20have%20a%20similar%20issue%20which%20is%20driving%20me%20more%20insane%20than%20normal.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-890543%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-890543%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20also%20looking%20for%20a%20solution.%20I%20have%20the%20same%20issues%20in%20my%20document%20library.%20Documents%20are%20there%20when%20view%20is%20on%20all%20documents%20but%20when%20I%20want%20to%20refine%20the%20results%2C%20documents%20are%20not%20found.%20(1%20instead%20of%2012%2F13%20show%20up).%20A%20few%20weeks%20ago%20everything%20worked.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1110139%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20modern%20list%20view%20not%20displaying%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1110139%22%20slang%3D%22en-US%22%3E%3CP%3EAlso%20a%20problem%20here.%20I%20have%20list%2C%20with%205%20different%20views.%204%20of%20them%20only%20have%20to%20bring%20back%20a%20small%20%25%20of%20the%20list%20and%20show%20correctly%2C%20but%20for%20some%20reason%20the%20main%20view%20which%20should%20be%20bringing%20back%20thousands%2C%20is%20always%20stucked%20a%203977.%20I've%20dropped%20all%20data%20in%20the%20list%20and%20repopulated%20it%20but%20the%20problem%20remains.%3C%2FP%3E%3CP%3EI%20can%20see%20there%20is%20over%206000%20items%20in%20the%20list%20but%20the%20view%20should%20show%20the%20first%205000%20(based%20on%20indexed%20column).%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Deleted
Not applicable

Hi

 

I hope you can help me.

I have a SharePoint site with multiple lists, which are all using the Modern list view.

A few days ago one of the modern list views aren't displaying items, even though there are more then 60 items in the list. If I switch to classic view all my items are displayed in the view.

 

Best

Thomas

Microsoft_Error_SharePoint_List_Modern_View_No_Items_01.pngMicrosoft_Error_SharePoint_List_Modern_View_No_Items_02.pngMicrosoft_Error_SharePoint_List_Modern_View_No_Items_03.png

20 Replies
Highlighted
This is very weird...have you opened a support case?
Highlighted

Have you tried to edit the current view for columns and see if it displays any list items.

https://support.office.com/en-us/article/edit-a-list-view-in-sharepoint-online-15916903-e79a-423f-b4...

Highlighted

Hi Juan

 

No, I haven't opened a support case yet, but that might be the solution.

Thanks for your reply.

Highlighted

Hi SPO Admin

 

I've tried to edit the current view, and have even created a new view to see if this would help, which it hasn't...

Microsoft_Error_SharePoint_List_Modern_View_No_Items_04.png

Highlighted

I started having this issue today. Any luck fixing it?

Highlighted

Sadly no, the problem persists in the "modern" layout.

Where using the "old" SharePoint 2013 layout, and here there's no problem.

Highlighted
Hei Thomas. If you create a modern page, and add the Document Library (preview) web part. Are you having issues with the web part not 'remembering' what view it should use, and falling back to the default view? We have this issue as well. Might be related.
Highlighted
Where you able to find answers to this issue?
Highlighted

Hi Alexandra

 

No, we sadly didn't find an answer to this issue.

The solution has been abandoned in favor of a newer version.

If you are experiencing the same issue, I hope you find a solution.

Highlighted

I'm having the same experience. So frustrating

Highlighted

I put in a ticket with Microsoft and they had to take a field that was required, change it to not required and then back and that worked. they couldn't really give me a why but it worked.

Highlighted

Did they let you know which field it was? How did you open the ticket?

Highlighted

They told me the field but said it didn't have anything to do with it, here is their response. Note list was not migrated but it still worked to fix the issue.

 

Was that list migrated?

Is yes, then sometimes the list schema gets corrupted and then toggling certain settings fixes the issue.

So, in your case schema might have been corrupted due to some reason and just by toggling the setting fixed it.

 

I'm GA in out O365 tenant so just opened in there.

Highlighted

I am having the same issue.  My list will not toggle back to "new experience".  I tried making a random required field not required, then required again, but that didn't change anything. This list has shown in modern view before.  This is a new development.  It occurred when I was testing ideas for color coding columns using JSON script which requires modern view.  A test list worked.  When I tried it on this list, I could not get the modern view to display. I removed the test column with the JSON and the list will still not display in modern view.

Highlighted

The reason for this is becuase there is a JSON programming within a list column that is no coded correctly. This is the way of the system saying that there is an error in the JSON formula. To fix the issue, go to the column settings for the column that has JSON formatting and review the formula or erase it. Once the formula is correct or erased, it will show the list in the modern view.

Highlighted
The reason for this is because there is a JSON programming within a list column that is no coded correctly. This is the way of the system saying that there is an error in the JSON formula. To fix the issue, go to the column settings for the column that has JSON formatting and review the formula or erase it. Once the formula is correct or erased, it will show the list in the modern view.
Highlighted

I wish it was that. there was no issue with the JSON it worked for a good week then this issue. Microsoft basically said the list got corrupt some how, didn't have anything to do with JSON. once i change required to not required and back it work. JSON was never changed.

Highlighted

Has any solution or explanation been found? I have a similar issue which is driving me more insane than normal.

Highlighted

I am also looking for a solution. I have the same issues in my document library. Documents are there when view is on all documents but when I want to refine the results, documents are not found. (1 instead of 12/13 show up). A few weeks ago everything worked.