Sharepoint loses JSON formatting on save

Copper Contributor

When saving a sharepoint item (editing or entering a field entry), the JSON formatting disappears and reverts to a single vertical list. Reloading the item brings back JSON format, but disappears again on saving.


Occurs for all users, and started in the last couple of days.


Offline Client Availability is still set to No (previous fix) and caches has been cleared. 


*******SOLVED- Fix was on Microsoft's side. They made an update that tripped up the JSON formatting. Working again as per 01/11/2022********


8 Replies

@DarcyOG I have observed many users are facing this same issue while using JSON formatting on list forms.

Similar threadSharePoint List losing Body JSON formatting on save temporarily 


I will suggest you to raise a support ticket with Microsoft directly and report this bug. Follow documentation: Get M365 support - online support 

Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

Hello, I got the same error that started on October 27th 2022. Everything was working fine before this date. I am facing this errors in all SharePoint lists and I tested in more than on site too. I found some tips but it didn’t work for me.



Please check in your computer the versions of Microsoft . NET Runtime, Microsoft Edge and Microsoft One Drive 22.212.1009.0004.


In my case I noticed that there was an update on october 26th of Microsoft One Drive 22.212.1009.0004 and I suspect that this can be causing the BUG. I also tested in other computer with other versions of Microsoft One Drive and there I did not face this error.


there are new versions of Microsoft . NET Runtime – 6.0.10 (x64), Microsoft Edge 107.0.1418.24 and Microsoft One Drive 22.212.1009.0004







It seems the error is related with new versions of Microsoft . NET Runtime – 6.0.10 (x64), Microsoft Edge 107.0.1418.24 or Microsoft One Drive 22.212.1009.0004 that can be related with this BUG.


I did a test in a computer with older versions of these software and  the json formatting is working fine even after changing a field.




Gilberto Ventura 

I'm not so sure about that one. I tried on another system running these older versions and the format reset still happens:
.Net Runtime 6.0.8
Microsoft Edge 106.0.1370.52
One Drive 22.176.0821.0003
The only other program updated recently was Microsoft Edge WebView 2 Runtime, but I've uninstalled this and problem still occurs.

What versions are you using on your older system?
The problem is really related with the latest update.
I have created a support ticket on Microsoft.
They have identified the problem and they are going to work on a solution.
"A recent change intended to update how SharePoint lists are viewed in Microsoft Teams caused a code regression that's resulting in impact."

I confirm that Microsoft has already solved this issue today, Everything is working fine again,
Yes. Noticed it working this afternoon. Thanks for raising that ticket