SOLVED

SharePoint List Form Configure Layout - Body Not Working

Occasional Contributor

Hi

I am formatting a SharePoint List Form following the Microsoft documentation Configure the list form | Microsoft Docs

Both the Form Header & Footer work well. However the Body does not! :sad:  It simply won't show when "Preview" is pressed and I get no errors on my JSON (copied below). I have tried to create more sections with less fields, but still - simply nothing happens! No error message nothing, when I click "Preview".

If I click "Save" it simply closes the form and when I open it again the JSON is gone. 

 

Can someone help?

I want to avoid creating a new form using PowerApps Integration as the changes we want are quite simple!

 

{

    "sections": [

        {

            "displayname": "Role",

            "fields": [

                "Resource Role"

            ]

        },

        {

            "displayname": "Details",

            "fields": [

                "Months",

                "Min Rate",

                "Max Rate",

                "Line Manager",

                "Project",

                "Geography",

                "Charge To"

            ]

        },

        {

            "displayname": "Contract",

            "fields": [

                "Contract Terms to Add"

            ]

        }

    ]

}

32 Replies

@Lynette_Hanson @alexr350 @BennoS @Klutzu2

 

I observed that lot of people are facing the exact same issues. I will recommend you all to raise a support ticket with Microsoft, check Get Online support


Please consider giving a Like if my post helped you in any way.

Same same, and I am waiting solution also
This is still happening. I tried for hours today and the code magically disappears the minute I save the page.

May be we turn to build form on Power APP :sad: @UnsuckM365 

I was hoping in this specific case to keep the form simple and light but I literally tried everything under the sun such creating list from blank, using pre built list, using content types and seconds after I save the form my code simply goes away. It does not seem to be a caching issue either because I tried it from multiple computers, incognito, mode etc...

@UnsuckM365 what happens is that once you save, extra syntax commas and brackets are added that makes its invalid, the way around that was to paste in Visual Studio Code or something similar where it can recognize JSON syntax and error out the ones that are not matching up and fix it there then copy it back but this is not a solution for sure because if you change anything it will do that again but if you dont it will stay the same.

To everyone having issues on this: The problem does not occur when I use a regular list with content type management turned off. Hopefully this is something that can be added in the future because site columns in the content type hub can have formatting added to them and they work just fine throughout multiple sites.

@Rosalia Dias I've been experiencing this issue a lot lately and it's never clear why. Some sites run fine with even higher complexity. I think the forms just get corrupt occasionally.

 

I have found a fix and I like it a lot. I was using a list with the content types not being editable.

  1. Go to a different site (anything other than the where the problem list is)
  2. I went to my sandbox site and clicked to create a new list (the new modern way)
  3. Then choose from Existing List
  4. Select the problem list
  5. Apply your fixes to the newly created/copied list (It worked perfectly in my sandbox)
  6. Return to problem list to delete it.
  7. Then go to the same List creation method in the problem list site, and choose the newly fixed list and created it.

So far its been working perfectly. I have tried so many methods. No content will be included so you may have to back it up so that you can add it back.

I have been experiencing this issue for a couple of days after everything working fine for two weeks on multiple lists so not sure what changed. A hard refresh of the page would bring it back but would disappear again on the next try.

I have solved this by turning off the sync for the list in List Settings > Advanced Settings > Set Offline client availability to No.

Obviously not ideal if that's the functionality you required but currently not required for my needs.

Hope this helps others and I'd be interested to know if it works for anyone else?

Didn't realize there was a thread on this already, started a new one few weeks ago.  

@Blue_Brumie - Turning off the sync from list settings worked for me too. 
I've been working with MS Support on multiple issues and the fix they recommended, disabling the sync - Lists sync policies - SharePoint in Microsoft 365 | Microsoft Docs, also fixed other issues we've been having so far.  After adding DisableNucleusSync, dword:1 as stated in the document, the formatting now sticks for all the lists I was having issues with.  We will be testing with more users this week.  It will need to get pushed out however to all the users once tested.  

@UnsuckM365 Oh thank you! Hasn't solved the problem, but at least I know why some of my lists work and others don't. It's those with Content Types allowed that aren't working for me too!

 

For my other lists the extra step of pressing Save and then F5 before closing the form does help make the changes 'stick' as well.

YES, thank you so much for this! Tried different browsers, clearing the cache, etc. Sometimes the formatting would come back, but more often than not I was just wasting my time and nothing would change. Disabling offline availability fixed it immediately, so I'm curious to see if it stays that way now, or if I'll need to toggle it periodically. Either way, this is likely gonna save me a tonne of time!

@ganeshsanap I have been seeing this problem intermittently. I have a calendar that I'm styling. When the calendar styling is incorrect then the form styling can't be updated. Closing the related pages, clearing the cache, and a brief pause seems to help. I've been using Edge. I may try Chrome.