SOLVED

SharePoint List Form Configure Layout - Body Not Working

Occasional Contributor

Hi

I am formatting a SharePoint List Form following the Microsoft documentation Configure the list form | Microsoft Docs

Both the Form Header & Footer work well. However the Body does not! :sad:  It simply won't show when "Preview" is pressed and I get no errors on my JSON (copied below). I have tried to create more sections with less fields, but still - simply nothing happens! No error message nothing, when I click "Preview".

If I click "Save" it simply closes the form and when I open it again the JSON is gone. 

 

Can someone help?

I want to avoid creating a new form using PowerApps Integration as the changes we want are quite simple!

 

{

    "sections": [

        {

            "displayname": "Role",

            "fields": [

                "Resource Role"

            ]

        },

        {

            "displayname": "Details",

            "fields": [

                "Months",

                "Min Rate",

                "Max Rate",

                "Line Manager",

                "Project",

                "Geography",

                "Charge To"

            ]

        },

        {

            "displayname": "Contract",

            "fields": [

                "Contract Terms to Add"

            ]

        }

    ]

}

32 Replies
I am seeing the exact same thing - I have customized forms on other sites with no issue but it's now showing up where the body, header and footer all just disappear on any new sites.
Hi, it seems to be, for me anyway a temporary issue, or worse an unstable one from Microsoft :( ! With the code above it is now working (for a few days with no issues), with absolutely nothing done from my end ... a mystery!
Thanks for the update, I'll just keep trying and hope it's a transitory issue..
best response confirmed by Rosalia Dias (Occasional Contributor)
Solution

@KevinBryan @Rosalia Dias 

 

I have observed this behavior as well on my SharePoint site. Try below things after "saving" the JSON in body section:

  • Refresh the page (hard refresh: Ctrl + F5 in windows)
  • Clear browser cache

It worked for me after hard refresh and I also think that this is a temporary issue from Microsoft side (maybe because of latest updates in SharePoint online).


Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

Anybody who found a solution as I am experiencing the exact same problem :\

Facing the same issue .@JHS2020 

Same issue here, it seems like SharePoint is adding an invalid JSON once you start rearranging the columns.

It is not working on subsites or teamsites. The format just crashes when an item is selected and the "Edit all" button is pressed.

Seems its still an issue. By clearing browser cache and hitting F5 it started working. But the list items which were opened in the past seems having some cache and they are not considering the formatting.

Hope this will be resolved soon.

 

@ganeshsanap I'm having the same issue, but the hard refresh did not work for me. Strangely, the loss appeared to happen in stages: after the first save, the edit form appeared to have the proper sections and a wide-screen format. After the refresh I opened a list item, and the edit form showed the proper sections, but in a vertical format. The next time I opened a list item (immediately after), the sections had disappeared.

I am facing a similar issue. After applying custom JSON, the preview is working. But after closing the form, all snaps back to before and the custom JSON is gone.
Same here. It is a sporadic between users and lists.
Seeing same problem but only on a particular list. Just wont save the JSOn whatever I do. Go to several other lists and apply formatting and works ok. Cam back to this one and still wont save. Please post up any further info if you guys fix it
I've done some testing on this. The first SharePoint List that I tried adding JSON to was a list "created from an existing list." This is the list that was problematic for me with the JSON. I had one of my SCAs recreate the list using ShareGate instead. Now I am able to configure the form with JSON as aspect.

@Klutzu2 BRUuuuh! this worked. I forgot I even created this one from another list but must have been.

Thankyou for your service.

Issue prevails with a list created from scratch (blank list) and a custom content type added.
See https://sharepoint.stackexchange.com/questions/299257/sharepoint-list-loosing-json-formatting 

Update: It worked when I first applied after creating new list. But now it won't take any changes to the JSON.
Will try to figure out what else is correlating.

@BennoS I too had the feeling it was working in the beginning, but I am not sure. Just discovered it later on.

Seeing the same issue today. Added header and body JSON, saved, all is fine. Went back later and changed the conditional rule for one field. It then stripped out all of the returns in my body JSON and also removed the Attachments field from a section and gave me the invalid JSON error. Once I added in all the returns again and re-added the Attachments field, it saved fine. But then I modified the column again and it stripped things out again. Very frustrating and a complete waste of time to have to keep fixing this.