SharePoint Drive Mapping Windows 11- Internet Explorer options locked out

Copper Contributor

Hi all seen a few issues and resolutions with Mapping drives using File Explorer and random disconnections.


I recently started building Windows 11 laptops but attached fixes the following problems, this should also work with Windows 10 and Edge


  1. Map a drive in SharePoint using file explorer
  2. Mapped drive random disconnections
  3. Windows 11 internet options showing greyed out and locked


21 Replies
this totally works for Windows 10 too, bravo

@Terry_Cole - just signed up to say thank you, this is a solution to a problem we have had for ages. Legend!

Happy to help, been a pain for us as well if you give us a like will promote solution
great share. it worked smoothly. thank you!
does this work longer than the 30 days that edge says IE mode will work ?
I have noticed that it will drop off after a few days and my fix is to re-open Sharepoint in IE mode and then the Windows Explorer view works again. I assume it must be a security related timeout or something similar...

I created a script that does it every time user logs in @Naude23 

Thanks for your help. Works great.

This is amazing, @Terry_Cole--thank you! Seconding Mike's question, would you be willing to share that login script for us to take a peek at?

Thanks for your help. Works great.

Since this post is where I kept looking for information about this, I wanted to provide an update:


In the past few weeks, Microsoft has started to block SharePoint Online addresses from being opened in Edge's IE mode, which ended our ability to use this workaround (as we could no longer generate that authentication credential.)


Fortunately, Microsoft has also added functionality into Edge and SPO to regain access to the WebDAV interface. It requires a tiny bit of configuration, the instructions for which are here:


We've rolled it out, and it's been working out great. If your environment prefers to stick with mapped drives, you can set up the new mapping once you use Edge to open any library in Explorer view once. (The authentication is good for the whole site, and not just whatever library you opened initially.)


Hope this helps someone. :)

Thanks for updates, as internet explorer has been dropped user with this solution will probably now have issues with Drive mappings, I have done a new guide that will hopefully help, appreciate link sent but a bit off a challenge first few times . See attached new updated guide, after you configure it's just a matter of copying explorer link and mapping drives @Terry_Cole 

@Terry66 thank you for this!!!  Worked great on the first computer I installed it on but cant get it to work on others in our office.  I have a question Step 1 says (one time only) and step 2 says (one time only per tentant)  does this mean step 1 only on one computer in my business and then start on step 2 for the rest of them?  I am getting the error in when I am trying to connect to the SPOS........ in the SharePoint Online Managment Shell



@calliej Ye the PowerShell bit only needs done once per tenant ( We manage multiple customers) so if you only have 1 MS Tennant that you login to then only one time, after you do it the Open with File manager will appear on SharePoint but will not work until you do Group Policy. If using a local AD Domain you can setup locally for all computers. Hope this helps

Thank you for the quick reply. I am not an IT person so Group Policy and AD Domain mean. We have 7 computers on our network and 365 business account. I am trying to map a drive on everyone's computer to sharepoint that will work just like an onsite backup has been working for years. I first used the onedrive link option and that allows people to get into the same drawing at the same time and is a disaster. LOL. So I have gotten the map to network drive to work on my computer and work as I like and need to install on the rest. Is Group Policy something in sharepoint or in windows settings. thank you so much!!!
All this has stopped working with a recent update however the way forward is to create a network location rather than map drive. It will work the same I have a guide will look to add