Need "" for SharePoint Server 2013 (KB3087184)

Copper Contributor

Hi all,


I'm running into the infamous "This product requires Microsoft .Net Framework 4.5" issue when installing Sharepoint 2013 onto Windows Server 2016. However, the links for the patch files no longer work, and someone erronously changed the links on the page to the service packs instead.


If anyone have the file for "SharePoint Server 2013 with Service Pack 1 fix", can you please share it here?


Link to the support article:


The original broken URL for "SharePoint Server 2013 with Service Pack 1 fix" was:


Thanks in advance!

4 Replies

If you do happen to find it, please post your final solution.

I am also running into this issue at this moment.

@bin4ry @tlangbroek the files appear to be gone but there is a work around.

  1. Disable Windows Update
  2. Stop any Windows services using a version of the .NET Framework greater than 4.5.x
  3. Remove all versions of the .NET Framework that are greater than 4.5.x
  4. Install SharePoint 2013 SP1 (I am a big fan of AutoSPInstaller)
  5. Enable Windows Update
  6. Let Windows Update install updates which will update your versions of the .NET Framework.
  7. Start all Windows services using .NET Framework or greater

To be careful you can note the versions of .NET you uninstalled (their KB number) and make sure they all get reinstalled.


I wrote an obligatory blog post on how to detect the versions of .NET that are installed on our machine using PowerShell, PowerShell: Determining the versions of .NET Installed on Windows  .


My machine had some tools (SSMS 2018, Edge, Chrome, Firefox, Notepad, Visual Studio Chrome with the PowerShell Extension). All of these could not be run while the .NET Framework was rolled back to 4.5.x. 


BTW: if you have in issue with the SharePoint 2013 SP1/SQL Server 2014 prerequisite .NET 3.5, I solved that issue too, meaning i know how to install it as it can no longer be installed user Server Manager.

best response confirmed by bin4ry (Copper Contributor)
I've also encountered this .Net Framework error problem this week.  I was attempting to install the "SharePoint Server 2013 with Service Pack 1" download from MSDN.  As a few of you have commented, the fix file ( is no longer available (broken links or erroneously pointed to the service pack which doesn't contain the fix).
I couldn't locate that fix file, but as a workaround I have got the install to work successfully by running the RTM install, "SharePoint Server 2013" downloaded from the MSDN website.  For whatever reason, this earlier version doesn't encounter that problem.  Then install the service pack.....
Hope this helps somebody.


Hi Phil,

Thank you for your response. Without the proper patched file, I think your method is the most straightforward solution.

However, this solution may not be feasible for everyone as my MSDN subscription doesn't give me the option to download the RTM release. After getting the image from a colleague, this method seemed to have worked.

Thanks again!