Multiple default views not working

%3CLINGO-SUB%20id%3D%22lingo-sub-260064%22%20slang%3D%22en-US%22%3EMultiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-260064%22%20slang%3D%22en-US%22%3E%3CP%3EUsing%20Sharepoint%20online%20I%20am%20trying%20to%20setup%20several%20different%20defaults%20views%20-%20fx.%20one%20for%20Top-level%20document%20library%20and%20another%20for%20files%20in%20folders.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-left%22%20style%3D%22width%3A%2081px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F53891iBE4736D784F47D10%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%222018-09-21_08-24-04.png%22%20title%3D%222018-09-21_08-24-04.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EI%20am%20applying%20both%20Top-level%20view%2C%20folder%20view%20and%20using%20content-type.%3C%2FP%3E%3CP%3EHowever%2C%20it%20seems%20like%20I%20cannot%20get%20both%20Folder%20and%20Top-level%20view%20to%20work%20-%20the%20system%20automatically%20applies%20same%20view%20to%20both.%20Any%20idea%20if%20that%20is%20no%20longer%20supported%20or%20why%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20using%20this%20guide%20as%20input%20for%20Folder%20and%20Top-level%20views%3A%26nbsp%3B%3CA%20href%3D%22http%3A%2F%2Fwww.cyberviva.com%2Fsharepoint%2Fdifferent-type-of-view-in-sharepoint-document-library-root-sub-folder%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttp%3A%2F%2Fwww.cyberviva.com%2Fsharepoint%2Fdifferent-type-of-view-in-sharepoint-document-library-root-sub-folder%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-260064%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDocument%20Library%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-293018%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-293018%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20same%20issue.%20Everything%20works%20fine%20in%20Classic%20experience.%20Changing%20to%20Modern%20will%20not%20switch%20views%20from%20top%20level%20to%20inside%20a%20folder%20view%20and%20back.%20In%20Library%20settings%20both%20views%20showing%20as%20default%20view.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-477457%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-477457%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F129285%22%20target%3D%22_blank%22%3E%40Villads%20Chester%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eyes%20we%20have%20exact%20the%20same%20issue.%3CBR%20%2F%3EDo%20you%20know%2C%20if%20there%20will%20be%20an%20update%20soon%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-557784%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-557784%22%20slang%3D%22en-US%22%3E%3CP%3EUnfortunately%20not%2C%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F248588%22%20target%3D%22_blank%22%3E%40lotz-hellerau%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-716912%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-716912%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F129285%22%20target%3D%22_blank%22%3E%40Villads%20Chester%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20have%20followed%20a%20similar%20guide%20to%20configure%20Content%20types%20and%20views%20for%20different%20folder%20levels%2C%20but%20nothing%20works%20as%20expected.%3C%2FP%3E%3CP%3EAny%20updates%20on%20this%20issuse%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance%3C%2FP%3E%3CBLOCKQUOTE%3E%3CHR%20%2F%3E%3C%2FBLOCKQUOTE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-896966%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-896966%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F365504%22%20target%3D%22_blank%22%3E%40lararodriguez%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3ENo%20unfortunately%20I%20did%20not%20find%20some%20news%20about%20it.%20This%20is%20really%20really%20bad.%3CBR%20%2F%3EDoes%20anybody%20has%20an%20idea%20why%20microsoft%20do%20not%26nbsp%3Bcare%20about%20that%20issue%3F%3CBR%20%2F%3EMaybe%20there%20are%20some%20other%20workarounds%20to%20do%20these%20things%3F%3CBR%20%2F%3EI'm%20afraid%20that%20dokument%20set%20content%20type%20does%20not%20work%20in%20SharePoint%20Lists%2C%20because%20there%20the%20view%20is%20switching.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EFor%20now%20I%20helped%20me%20by%20formatting%20the%20name%20column%20of%20the%26nbsp%3Brelevant%20list.%20Now%20when%20users%20klick%20the%20name%20column%20the%20view%20is%20changing%20to%20the%20view%20I%20specified.%20But%20this%20is%20not%20very%20handy!%3CBR%20%2F%3EWe%20really%20need%20some%20update%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-909231%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-909231%22%20slang%3D%22en-US%22%3ESame%20here.%20Same%20issue.%20Why%20they%20would%20remove%20this%20issue%20is%20beyond%20me.%20There%20are%20a%20lot%20of%20uses%20for%20it.%20Can't%20see%20what%20it%20harms.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1121165%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1121165%22%20slang%3D%22en-US%22%3EI%20am%20also%20experiencing%20the%20same%20issue.%20The%20defaults%20work%20correctly%20in%20the%20classic%20experience%2C%20but%20not%20in%20modern.%20Defaults%20set%20for%20Document%20Sets%20do%20work%20correctly%2C%20but%20not%20for%20any%20other%20content%20type.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1137872%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1137872%22%20slang%3D%22en-US%22%3E%3CP%3EI%20see%20that%20the%20last%20comment%20on%20this%20was%20a%20couple%20of%20months%20ago%20but%20I'd%20just%20like%20to%20chime%20in%20that%20we're%20experiencing%20the%20same%20behavior.%26nbsp%3B%20We've%20got%20a%20library%20with%20a%20top%20level%20view%20of%20All%20Documents%20and%20then%20within%20the%20top%20level%20folder%20there%20are%20sub-folders%20that%20are%20assigned%20to%20different%20default%20views.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EI%20used%20the%20example%20outlined%20in%20this%20link%20-%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fcamerondwyer.com%2F2014%2F01%2F06%2Fharness-sharepoint-default-views-at-different-navigation-hierarchy-levels-to-build-more-appealing-solutions%2F%23customfolder%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fcamerondwyer.com%2F2014%2F01%2F06%2Fharness-sharepoint-default-views-at-different-navigation-hierarchy-levels-to-build-more-appealing-solutions%2F%23customfolder%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EAs%20others%20have%20pointed%20out%2C%20this%20works%20well%20in%20Classic%20View%2C%20the%20issue%20is%20that%20we%20are%20using%20Modern%20View.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20hope%20find%20a%20solution%20by%20continuing%20to%20search%2C%20but%20for%20now%20the%20issue%20persists.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1335300%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1335300%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F537633%22%20target%3D%22_blank%22%3E%40jbryant%3C%2FA%3E%3C%2FP%3E%3CP%3EThe%20same%20for%20me%2C%20stil%20no%20solution%20for%20Modern%20Site%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1485041%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1485041%22%20slang%3D%22en-US%22%3EEnd%20of%20Jun%202020%20-%20still%20an%20issue%20for%20modern%20experience%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1626590%22%20slang%3D%22en-US%22%3ERe%3A%20Multiple%20default%20views%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1626590%22%20slang%3D%22en-US%22%3ESame%20issue%20here.%20Did%20not%20find%20a%20solution%20yet%20either.%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Using Sharepoint online I am trying to setup several different defaults views - fx. one for Top-level document library and another for files in folders.

2018-09-21_08-24-04.png

I am applying both Top-level view, folder view and using content-type.

However, it seems like I cannot get both Folder and Top-level view to work - the system automatically applies same view to both. Any idea if that is no longer supported or why?

 

I was using this guide as input for Folder and Top-level views: http://www.cyberviva.com/sharepoint/different-type-of-view-in-sharepoint-document-library-root-sub-f...

 

12 Replies
Highlighted

We have same issue. Everything works fine in Classic experience. Changing to Modern will not switch views from top level to inside a folder view and back. In Library settings both views showing as default view.

Highlighted

@Villads Chester 

yes we have exact the same issue.
Do you know, if there will be an update soon?

Highlighted

Unfortunately not, @lotz-hellerau 

Highlighted

@Villads Chester 

Hi,

I have followed a similar guide to configure Content types and views for different folder levels, but nothing works as expected.

Any updates on this issuse?

 

Thanks in advance


 

Highlighted

@Deleted 
No unfortunately I did not find some news about it. This is really really bad.
Does anybody has an idea why microsoft do not care about that issue?
Maybe there are some other workarounds to do these things?
I'm afraid that dokument set content type does not work in SharePoint Lists, because there the view is switching. 

For now I helped me by formatting the name column of the relevant list. Now when users klick the name column the view is changing to the view I specified. But this is not very handy!
We really need some update :)

Highlighted
Same here. Same issue. Why they would remove this issue is beyond me. There are a lot of uses for it. Can't see what it harms.
Highlighted
I am also experiencing the same issue. The defaults work correctly in the classic experience, but not in modern. Defaults set for Document Sets do work correctly, but not for any other content type.
Highlighted

I see that the last comment on this was a couple of months ago but I'd just like to chime in that we're experiencing the same behavior.  We've got a library with a top level view of All Documents and then within the top level folder there are sub-folders that are assigned to different default views. 

I used the example outlined in this link - https://camerondwyer.com/2014/01/06/harness-sharepoint-default-views-at-different-navigation-hierarc...

As others have pointed out, this works well in Classic View, the issue is that we are using Modern View.

I hope find a solution by continuing to search, but for now the issue persists.

Highlighted

@jbryant

The same for me, stil no solution for Modern Site 

Highlighted
End of Jun 2020 - still an issue for modern experience
Highlighted
Same issue here. Did not find a solution yet either.
Highlighted

We're having the same issue. It's incredibly annoying because we would like to use different views depending on where you are in the library but this is not possible. The only solution I've found is to make new document libraries but that has the problem with not being able to redirect Teams channels file locations to these new document libraries. It's really idiotic that MS does not fix this. It worked before, why does it not work now...