Modern SharePoint list not displaying image directly in picture/hyperlink field.

%3CLINGO-SUB%20id%3D%22lingo-sub-457084%22%20slang%3D%22en-US%22%3EModern%20SharePoint%20list%20not%20displaying%20image%20directly%20in%20picture%2Fhyperlink%20field.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-457084%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EModern%20SharePoint%20list%20not%20displaying%20image%20directly%20in%20picture%2Fhyperlink%20field.I%20get%20broken%20link%20symbol%20like%20in%20the%20pic%20below.%20used%20doc%20library%2C%20site%20assets%20as%20pics%20resource.%20Both%20ways%20it%20didn't%26nbsp%3Bdisplay%20the%20image%20in%20JPG%26amp%3Bpng.%20your%20hep%20is%20appreciated%26nbsp%3Bpls%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-457084%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-483265%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20SharePoint%20list%20not%20displaying%20image%20directly%20in%20picture%2Fhyperlink%20field.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-483265%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F295781%22%20target%3D%22_blank%22%3E%40MDEL90_El%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20you%20give%20examples%20of%20the%20link%20you%20are%20setting%20for%20the%20hyperlink%3F%26nbsp%3B%20I%20assume%20you%20have%20permissions%20to%20access%20it.%26nbsp%3B%20I%20just%20tested%20this%20and%20it%20works%20fine%20for%20me.%26nbsp%3B%20I%20used%20a%20direct%20link%20and%20a%20link%20created%20with%20shared%20with%20and%20they%20both%20work%20just%20fine.%26nbsp%3B%20Is%20the%20picture%20published%2C%20or%20a%20major%20version%3F%26nbsp%3B%20Example%20of%20mine%20working.%26nbsp%3B%20I%20uploaded%20picture%20to%20doc%20lib%2C%20got%20a%20link%2C%20and%20populated%20the%20Hyperlink%20column%20in%20a%20list.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F110522i183844D6DEAB6DE7%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22hyperlink.JPG%22%20title%3D%22hyperlink.JPG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-500025%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20SharePoint%20list%20not%20displaying%20image%20directly%20in%20picture%2Fhyperlink%20field.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-500025%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F5855%22%20target%3D%22_blank%22%3E%40Doug%20Allen%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESame%20pic%20URLs%2C%20using%202%20ways%20of%20copying%20the%20link.%26nbsp%3B%3C%2FP%3E%3CP%3EThe%201st%20long%20URL...by%20clicking%20on%20the%20picture%20and%20copied%20from%20the%3C%2FP%3E%3CP%3Enew%20opened%20browser%20tab%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%202nd%20short%20URL%20...by%20copying%20from%26nbsp%3B%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20167px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F110959i2C080DDC0D4063C7%2Fimage-dimensions%2F167x22%3Fv%3D1.0%22%20width%3D%22167%22%20height%3D%2222%22%20alt%3D%22Capturec.PNG%22%20title%3D%22Capturec.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20dark%20ink%20highlighted%20are%20tenant%20name%20-%20Associated%20site%20created%20in%20the%20Hub%20named%20(blabla_bla)%20-%26nbsp%3B%3C%2FP%3E%3CP%3Eless%20than%20255%20character%20in%20both%20cases%2C%20Jpg%20(tried%20diff%20png%2C%20jfif%2C..etc%20)%20%2C%20this%20uploaded%20to%20SiteAsset%20(%20tried%20by%20uploading%20in%20doc%20lib%2C%20site%20Library%20%26amp%3B%20any%20other%20workaround%20you%20imagine%20but%20no%20avail%2C%20lastly%20it%20only%20works%20if%20I%20upload%20to%20pic%20library%20nothing%20else%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20142px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F110962i32B8B01BDB26B4DC%2Fimage-dimensions%2F142x91%3Fv%3D1.0%22%20width%3D%22142%22%20height%3D%2291%22%20alt%3D%22Capturett.PNG%22%20title%3D%22Capturett.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20952px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F110957iDEBB899F72DA2A49%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Capturex.PNG%22%20title%3D%22Capturex.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Modern SharePoint list not displaying image directly in picture/hyperlink field.I get broken link symbol like in the pic below. used doc library, site assets as pics resource. Both ways it didn't display the image in JPG&png. your hep is appreciated pls

2 Replies
Highlighted

@MDEL90_El,

 

Can you give examples of the link you are setting for the hyperlink?  I assume you have permissions to access it.  I just tested this and it works fine for me.  I used a direct link and a link created with shared with and they both work just fine.  Is the picture published, or a major version?  Example of mine working.  I uploaded picture to doc lib, got a link, and populated the Hyperlink column in a list.  

 

hyperlink.JPG

Highlighted

@Doug Allen 

 

Same pic URLs, using 2 ways of copying the link. 

The 1st long URL...by clicking on the picture and copied from the

new opened browser tab

 

The 2nd short URL ...by copying from Capturec.PNG

 

The dark ink highlighted are tenant name - Associated site created in the Hub named (blabla_bla) - 

less than 255 character in both cases, Jpg (tried diff png, jfif,..etc ) , this uploaded to SiteAsset ( tried by uploading in doc lib, site Library & any other workaround you imagine but no avail, lastly it only works if I upload to pic library nothing elseCapturett.PNG

 

 

 

Capturex.PNG