Link Web Part Not Generating Preview

Occasional Contributor

Here is the code for a trivial Web Page I am hosting in IIS on a Non-SharePoint machine:

<!DOCTYPE html>
<!-- Saw this in the source at -->
<html prefix="og:" dir="ltr" lang="en" class="no-js">
<title>Testing URL Preview 2</title>
<!-- Saw these meta tags on CodeShow a long time ago -->
<meta name="keywords" content="URL Preview Test Two" />
<meta name="description" content="Trying to figure out why URL Preview works inconsistently." />
<meta name="author" content="Shawn Eary" />
<meta name="dateCreated" content="06/25/2019" />
<meta name="copyright" content="(c) ©2019 - University of Arkansas (Test Site)" />

<!-- -->
<meta property='og:title' content='URL Preview Test Three' />
<meta property='og:site_name' content='Test' />
<meta property='og:image' content="" />
<meta property='og:type' content="article" />
<meta property="og:description" content="Why doesn't URL Preview Work consistently?" />

This is a test page.

When I the type the URL for that Web Page into a Link WebPart on SharePoint Online, I get this "error":
"There's no preview available for this link."

What do I need to change in the above code, to get the Link Web Part of SharePoint Online to display a preview?

14 Replies

BTW: I know this is off topic, but it would be nice if this forum:

  1. Allowed me to edit my posts
  2. Would pretty format my code

I'm still having problems with this.  As an example, if I post this URL in MS Teams:

I get a URL Preview:

but when I try to put the same URL in the Link WebPart of a SharePoint Online page, I get a "There's no preview available for this link." message:


@Shawn Eary  Having the same issue, but it shows the preview on some SharePoint sites and not on others for the same exact link.

Exactly the same issue, no preview in Link Web part

What's the trick?

best response confirmed by Shawn Eary (Occasional Contributor)

It seems like a bug - especially considering that the Use the Link web part page shows a preview image to an external site.


I'll report it to MS Support and report back.



Is the Link web part working for you now?


It seems to be for me.


@Norman Young- The Link WebPart is working for all of the links you just mentioned but it still doesn't work on our SharePoint Online site for these URLs:

It should be noted that all of these URLs generate at least some part of a Preview in our instance of MS Teams.

Hi @Shawn Eary,


Odd behavior. The links you provided work for me. 


Thumbs up for GCN - I enjoy their content.



@Norman Young- Yes, I'm getting odd behavior.  The previews for all of those links are partially working for me now also IF I don't type a space after URL.   For some reasons, if I type in a space after the URL on each of those links, I get a "There's not preview available for the link." message.

This isn't serious since the workaround is to simply not put in a space at the end of the URL, but even when I don't put a space at the end of the URL, I still only get a limited quality preview.

For example in SharePoint with the Link Preview web part I get this limited preview:
but in MS Teams, I get this much richer preview:

So I have two oddities.  The first is not serious since there is an easy workaround (just don't put a space at the end of the URL), the second is a little disappointing because the SharePoint Preview seems to be of a lower quality than the MS Teams preview.  The second problem is not necessarily restricted to .  There are other URLs that also seems to display in "full" preview for me in MS Teams but "limited" preview for me in the SharePoint Link WebPart.

@Shawn Earythe Teams link preview does seem like a richer experience. Perhaps the SPO Link web part may get the same treatment down the road.


Glad to hear you have found a work around.



@Norman Young, there's no space at the end of my URL, and it still says

"There's no preview available for this link."  also, it displays nothing in MSTeams either. 

@Norman Young 
I'm having the same issue in my SharePoint link doesn't display a preview.
I tested with my URL's and with the global cycling/ sites but still get unable to preview.
There are no spaces at the end so that doesn't seem to be it.
All show previews when I post them in Teams. 

Is it possible that its a site setting ?  (I'm new to SharePoint so just throwing out ideas).


@El-destructo I know this sounds ridiculous, but now maybe you should try purposefully putting spaces at the end of your URL.  The point is that IMO the ability of Microsoft Tools to adequately generate Link Previews across various products seem to be related to:

  1. Characters appearing at the end of the URL
    (spaces, tabs, LineFeeds and/or Carriage Returns per Comments from Other Users Above)
  2. Available CPU resources and/or system load

I know this all sounds very stupid, but I've had problems with URL previews in more than one Microsoft product, and in general, the feature feels very "buggy".  It doesn't seem to work consistently in numerous Microsoft tools.  With that said, seems MS Teams Desktop client and Outlook Web Access (also are more reliable at generating link previews than some of the other tools.  My personal experience for example is that the built in Windows 10 20H2 Mail client seems to be highly unreliable for generating URL previews but maybe I just have a "slow" computer [1]...

Yes, I know this is about SharePoint, but seriously, I have had notable problems with Microsoft products generating link previews.

OFF Topic:  Another thing that really annoys me is that when I create a LinkedIn (owned by Microsoft) or SharePoint Post with an image, a lot of the times, both products seem to pick arbitrary sections of my thumbnail image despite the panning and cropping settings I have chosen elsewhere.   I don't have time to correctly document this now, but it's highly annoying, because I've had SharePoint and LinkedIn do stupid stuff like cut people's heads off or remove "critical" parts of my thumbnails despite panning and image resizing attempts.

[1] - You would think two Xeon X5675's with 48 GB of RAM would be fast enough but apparently not.  Maybe it's my 7200 RPM Mechanical HDs slowing everything down...

@Shawn Eary 

Sadly adding a variety of space, / ,tab etc isn't doing anything.
Very annoying that you can't edit a link after creating but need to create a new one every time.
Also tried in chrome/edge/firefox .
My laptop is no slouch so resource usage is fine. Just seems to be a bug that 18+ months later still hasn't been addressed.