Is it possible to disconnect a site from an O365 group?

Contributor

I'm interested in keeping a site collection that is connected to an Office 365 group, but I want to delete the group and "disconnect" it from the site (basically the opposite of what is possible when you "groupify" a team site). Does anyone know if this is a PowerShell command?

11 Replies
AFAIK, once you have a Group there is not way to disconnect the SharePoint Site from the Group

@Juan Carlos González Martín if you do find out how to do this, please let me know. 

@Andrew Warland I would create a new team site and migrate the content between the sites.

The issue that we had was that we used the 'connect to new Office 365 Group' and then forgot to use the correct naming convention, which was not an idea situation.

 

As it is not possible to disconnect the site from the new group to do it again, we were able to fix the group (email address) name via these instructions:

https://techcommunity.microsoft.com/t5/Office-365-Groups/Is-there-a-way-to-change-O365-group-email-a...

@Andrew Warland @Bynum Hoekstra  I didn't try this. But, you can take a look at the command available in PowerShell. 

 

https://docs.microsoft.com/en-us/powershell/module/sharepoint-online/remove-spositegroup?view=sharep...

 

-Praveen.

@Praveen_Battula Thanks for the link! I'll try to check it out sometime soon. 

@Bynum Hoekstra have you been able to test the PS script to see if you're able to disassociate a team site from O365 group?

Hi, It seems that this command is for removing Site Groups (and not O365 Groups), as it's mentioned in this issue.

@Praveen_Battula this remove SharePoint Goups but not Microsoft 365 Groups

@Bynum Hoekstra Agreed. What a mess in Azure when you create a Team Site? An O365 Microsoft Group is auto-created as the name of the site, but the Groups <Site Name> Owners, < Site Name> Members and <Site name> Visitors are created. Now for some reason the <Site Name> Owners is no longer selectable in SharePoint Online (someone may have deleted) and yet still shows as exists in Members of Site. So basically I need to do the same as disconnect this site from the O365 Group.    

This is after waiting days so has surpassed the 24 hour period.