Imported Excel File Columns not showing in form

Occasional Contributor

Recently imported an excel file into a SP List everything imported successfully. However when I go to enter a new entry the columns that I imported aren't showing in the form. I tried to go to configure layout and there are not found there. Any idea?

11 Replies
Anyone know a solution?

Same issue - no idea, keen to get an answer, as it's a bit of a problem! @jcurrie94 

I'm seeing the same issue and haven't found any resolutions online yet. Has anyone else?
Couple notes:
1. Issue was not present a couple of weeks ago
2. After importing my excel document I only see the Title and Attachment fields on the new and edit forms. None of my imported excel fields are showing.



Okay - I have the answer:


  • Go into the list Advanced settings and set 'Allow management of content types?' to YES
  • When you leave the Advanced settings you'll see the Content type(s) showing on the screen above the columns you have
  • Click on the content type (it's a link) - for me it was 'Item'
  • Once into 'Item' I was able to add the columns imported via Excel, to the content type 'Item'
  • After that - they showed up in the 'form view'

I hope it helps!




Chris, This worked! Thank you for the workaround!! Hopefully, MS can get the issues fixed, but for now, I'm good with using the workaround. :)
Thank you so much!!! This worked beautifully!

@Chris_McCann Hey Chris, After I enabled Allow Management of content types, my form is still not showing all the columns. 



I was able to get them added to the form by adding them to the Content Type Item however when I try to rearrange the columns in the form it will not save. Any ideas?

@jcurrie94 I was able to successfully change the form field order by:
! After adding the imported fields to the Item content type
  1. Turn off "allow management of content types" 
  2. Go  List Settings and selecting the Column ordering link in the Column section and change the order of fields here and saving


Hope this works for you as well.

Thank you Chris, worked like a charm.
I'm also still seeing this issue, even with "Allow Management of content types" enabled.

Any other considerations here @Chris_McCann ?