Error: Column validation failed when evaluating formulas [Need Assistance]

New Contributor



I have a SharePoint list that I have been using and it has been working fine. The next day I go on, and I get the following message when trying to add or edit an item: 


Error: Column validation failed when evaluating formulas


Here is what I have tried:

  • Another person to add/edit an item (they can)
  • Restarting my computer and logging out/into my account
  • Making sure my system is up to date
  • Clearing my cache
  • Editing existing items in the list (doesn't let me save it - I get the error)
  • Accessing the list from an Apple Device (I can add/edit)

I have not played around with any of the settings or formulas. I am putting in the same values as I did before. This error simply came out of "no where". Any advice or tips what to try next?


Thank you in advance!

38 Replies
Hello I have the same exact situation. Have you gotten any fix
Also having this issue, we are on office 365 here if that matters.
I have been using this same sharepoint task entry screen daily and now it errors out?

Experiencing the same issue after modifying my SP list. Thanks for sharing useful information

@Jakub_Wolak Same issue here with a new list based off the Issues list.  Tried to add new columns and get "Error: Column validation failed when evaluating formulas" even with just a text only column


Still having the same issue...

Please let me know if anyone has it solved!

Same here. Following this for the resolution.


We had the same problem and it started off around March 11, 2022. 
The error reads validation failed when evaluating formulas so I went and deleted the only column which was calculated under list settings. It seems to me that the formula has gone wrong or not working anymore as we had not created this column and were using the list from the template. After we deleted this column, it was working fine again. 

Same issue with a brand new list. Added 2 items, and now it returns the error whenever I try to add something.
I have the same issue. I have my SharePoint list added to Teams. When someone tries to add a new item via TEAMS they get the error. So they open via SharePoint and they can add an item. Others cannot add an item using either method. This is a fairly new Issue Tracker list, and has been working fine until last week.
Please help.
Same issue here and began on 11MAR22.
Odd thing is co-worker copied and reused my list and hers is still working. I compared calculated field formulas and they are the same. I hate to delete the field that was suggested by @Pradeep_Kumar2205 (it is useful) -- any other suggestions that worked? (Could the field be added back after deletion with the same formulas? )
Solution: Hello, I found out as I delete in template of task list the calculated column called as Days old or smth like that, my issue was solved. I hope that it helps also all of you.



This appears to be an issue arising from the Microsoft edge browser update. Version 99.0.1150.39: March 10

Error does not appear in Chrome.

This helped me. I deleted the Days Old column. that fixed the issue for us. Thank you!!!

@Big_D_UK : I have the issue in Chrome (Chrome Version 99.0.4844.51 (Official Build) (64-bit))

Agreed - this appears to have started recently with that version of Edge, and Chrome still works fine.
Deleting our Days Old calculation fixed my issue. Thanks to all for your input on this.
I did have this issue in both Edge and Chrome browsers. All fixed now.
Hi , will like to know how you delete the Days Old in the current format? I try to edit but cannot