Document Library URL Links not working

New Contributor

Just started having this issue on one of our site collections where the URL links in a document library are not opening.  I tried adding new links to this document library and they won't open, but If I add a new document library and add links, they open just fine. This was working fine a couple of days ago.  Any body have any insights?DocLibraryTest.jpg


21 Replies

@ndesai24 its just working fine for me

Only thing I can think of is your link content type changed somehow or something with the view no longer being default? Maybe try making a fresh view and trying from that. Also assuming this library isn’t a webpart of the library which the document library webpart does not work with links only the default full view of the library.


I am experiencing the same issue in the GCC in modern libraries. If I open the library in File Explorer the links work. My guess is if I converted back to classic they would work and that it's an issue with modern libraries. I will be contacting MS momentarily.

@ndesai24 I'm having the same issue, did you ever find a solution? 


Same issue... :( do you get a solution ?

@Vincent NOISET 

I have a solution, unfortunately it is not the best.  The only solution we have found so far is to create a new document library and copy the document links and files over there and it seems to work.  Any of the old document libraries in this specific site collection do not work, but new ones do. 


Hello @ndesai24 

thank you for the feedback.  In the meantime I discovered that if I open the same doc lib in IE11 the link is working, but not in Chrome.

So it could be browser related issue (in my case).



I had the same issue and found that the parent directory name starts with a hashtag character (#BusinesCase). After renaming the mentioned directory to regular chars the links worked again.

Hope this helps,


This exact problem is happening to us now, just started today. I can't click any links. There are no special characters in the folder names. I tried creating a new view and no go.

@Paul33 can you upload a screenshot of the view?

We are also experiencing the same problem

Ok so here was our solution - we had "URL with edit button" as the field that was being displayed. For whatever reason this week all of our lists stopped working. I unchecked that field and chose "URL" and now it is working.


Was there an update to sharepoint? I'm not sure why all the sudden all of our working lists would break. 

@Paul33 thank you so much, ours is now also fixed!  It appears the "URL with edit field" has now been labelled "old", so I also changed the view to "URL" and working.

@Carbella77 we are currently investigating this behavior

@Bruno Aleixo Same issue. Please update if you've found a remedy.

@Marty885 please follow message center with id SP210119.



This just started happening with one of our sites in our tenant. Your picture is exactly like our links appear. do you find a solution?
@Paul33 can you provide more details and screenshots on how you got this to work?



Where do we get this option?


I am unable to find it