Add and Customise Pages permission denied yet I am site admin have full control



I have even added a new permission group at site level with just add / customise permissions. (as shown in screen shot)

I am a site collection administrator

I am the site owner and have full control

It is a modern communication site

What is going wrong?

2 Replies

@SarahTurner : Same issue I faced and it took lot of time to resolve. Below two solutions try any one of the below and check:

A] To enable or disable scripting from the SharePoint admin centre.

1)Sign in to Office 365 with your work or school account.

2)Go to the SharePoint admin centre.

3)Select Settings.

4)Under Custom Script choose below setting:



Note: It will take 24 hours to take effect.


B] Use the following PowerShell command.

a) Open SharePoint online management shell

b) Enter Connect-SPOService

c) Enter URL of admin site https://<yourdomain>

d) username and password

e) Set-SPOSite -Identity https://<yourdomain> -DenyAddAndCustomizePages $false


Note: It will take 24 hours to take effect.


If I have answered your question, please mark your post as Solved.

If you like my response, please give it a Thumbs Up.

best response confirmed by SarahTurner (Contributor)

Ok so I think I have solved this myself! 
It seems as though navigating to the page library and clicking 'New' and selecting any content type doesn't work - regardless of permissions.

However just going to the home page and selecting New / Page works perfectly and gives me loads of options and stores them happily in the Page library!

Is this just a functionality change on modern sites maybe?

Anyway, found a solution.