Flow runs successfully but does not create item in SharePoint List

Copper Contributor

Hi all!

 

I have a flow running that is triggered by the completion of a MS Forms questionnaire, creates an item for each filled out form in a SharePoint List, and subsequently emails me to notify me of new entries.

This has been running smoothly for several months now.

As of today, it seems, it no longer manages to create an item in the SP List. However, the flow runs are successful, I receive my notification emails and everything else the flow is supposed to do works fine. I cannot find a fault in the flow or its run history. By all accounts in Power Automate everything is working as usual, but my SharePoint List is missing the newest entries.

Any ideas where the error might be?

7 Replies

@JHingst make sure you haven't used the Forms template which puts in an illogical apply to each which often causes errors.

 

Rob
Los Gallardos
Microsoft Power Automate Community Super User.
Principal Consultant, SharePoint and Power Platform WSP UK (and classic 1967 Morris Traveller driver)

Thank you for your reply! :)
I built the flow my scratch myself. And it worked perfectly up until recently. I made some small changes over the last week (i.e. add some answer choices to multiple-choice questions) but tested those and they have worked fine before too.

Hi @JHingst ,

how many items are in your SharePoint list right now? More than 5000? (You can check that by looking at the "Items" column in  "Site Contents"). Does that number update if you run the flow again?

Perhaps the items are being created in your list, but the list view exceeds 5000 elements. So you don't see them in your views.

Best Regards,
Sven

Hi @SvenSieverding ,
Thank you for your reply! I had not thought to check in the 'Site content' section, because there are only 13 visible items in the list. The 'items' column in 'site contents' shows 17 though, and goes up with a new submission. So its a visibility issue. (We're getting closer :) )
The only saved view for the list is 'All Items' which is the one I'm using.

Hi @JHingst ,

ok, in that case we can check a few more things;

1) Are any draft item settings turned on (Gear->List Settings->Versioning Settings)?
2) Are Item level permissions set to anything other than "Read all items"? (Gear->List Settings->Advanced Settings)?
3) Has the "All Items" view a filter (Gear->List Settings->Scroll down to "Views"->All Items-> Scroll down to "Filter")?

Best Regards,
Sven

@SvenSieverding 

thanks for your assistance!

None of these suggestions apply, though, so the issue must lie somewhere else.

 

Best,

JHingst

Somehow, the issue seems resolved. I have not made any changes to any settings, but all of a sudden it is working as intended, and as it used to.
I have no explanation for this :D