Zoom link not responding in Outlook Mobile

Iron Contributor

Hey Fam,


I have a weird problem with Outlook for iPhone, and it doesn’t happen all the time!


When I create a Zoom meeting with another location, a physical meeting room (as resource in Exchange), the Zoom URL in the calendar is not clickable.


I tried create a Zoom meeting within Outlook Desktop using Zoom plugin. I also tried to create the Zoom meeting from Zoom portal, which doesn’t let me to add the exchange resource (the meeting room). So I create it first, then open the event in Outlook desktop and add another meeting room under the location. 

Both ways I find the Zoom URL is not clickable, because it has an arrow behind it. The reason I did it via the Zoom portal is to eliminate the possibility of Zoom plugin.


This doesn’t happen if I only create the Zoom meeting with no additional location (no meeting room).


Has anyone seen this before? Apparently it only happens to iPhone. But again it doesn’t always happen, and it could be on any of the iPhone model/OS version, which makes it very tricky to troubleshoot. 

I also tried Outlook log with MS support, so far couldn’t find anything.



2 Replies

Just to make my odd issue a bit more clear, below are two meeting events in my iPhone Outlook calendar.


Both meetings are a Zoom URL with a second location of a meeting room (Exchange resource).


The Zoom URL with an arrow behind does not work. When you tab the Zoom URL, the Outlook does nothing.


The one without arrow behind works as normal. When you tab the Zoom URL, it will call the Zoom app. If your Zoom app is not already signed in, it will call the Browser for SSO.



I want to follow this as I also have someone in my Org who is experiencing this same issue. For this user when we click into the details of the meeting from his Outlook Mobile calendar then long press the URL within the details then click Open it will launch the Zoom mobile app and connect to the meeting but the meeting URL in the location of the calendar does nothing when you press on it, neither does the Join button. Have you found any resolution to this yet?