No RSVP option in email invitation

Copper Contributor

Hi ! I have an issue on Outlook iOS app. My boss found the RSVP option in email invitation is missing. I tried to reset account / delete account / remove and reinstall the Outlook app on his mobile, the RSVP is still missing. Tried to access Outlook web from Safari on mobile, RSVP shows fine. At first I thought this may be the problem of his mobile, but I checked my boss 's other mobile devices (second iPhone and iPad), same issue is found. Anyone having this problem? Or any suggestion to fix this problem?

6 Replies

@jerryngan Did you ever find a resolution for this?  I have one end user with the same issue.  No RSVP option on any of his devices.  It looks like you've tried most everything you can do from the actual device.

@intensert No solution. I raised support ticket to MS support team from M365 admin center but be told that mobile issue is out of their scope and keep request me to ask for help from Outlook mobile app.


Mobile app support team asked me to test many things but still not able to find the root cause. Most latest thing the support team want me to test - Remove the user account delegation. I haven't test it yet and I will leave message here if I have result.

@jerryngan Thanks for the update.  My user also has a delegate.  He removed and re-added, did not change anything.  I don't know that he tested it with the delegate removed.  I'll see if he can try that.


I also have opened a case from admin center.  Fun fact, he had never heard of the RSVP option before so we have that going for us.

@jerryngan  Check the Send my meeting-related messages to delegates setting in Outlook to find out what's been configured. This can be done from the Outlook desktop client.


Here are the mobile behaviours for each option:

My delegates and me = RSVP is available for mailbox owner

My delegates only, but send me a copy = No RSVP for mailbox owner
My delegates only = No RSVP for mailbox owner

Thanks @eglockling, that lines up with what MS is thinking.


I just heard back from our MS Escalation Engineer today that this is likely part of a known issue and a fix is currently pending release in production.  So that is good news.


From the Escalation Engineer:

I understand that the issue is related to Outlook for iOS user missing RSVP option for meeting invites. It appears this user may be running into an emerging issue.

Does this affected user have a Delegate? If so, what are the permissions granted to the Delegate?

To check from Outlook desktop, go to File - Account Settings - Delegate Access

Once a delegate name is highlighted, select 'Permissions'

Is the Calendar permission set to 'Editor'?

Is there a check-box for "Delegate receives copies of meeting-related messages sent to me"?


Also, on the affected user's main delegate setting screen, what is the radio button set to (see highlighted options below)? 





For this known issue, the product engineering team has investigating the issue and a fix is currently pending release to production. Once we confirm if the user is hitting this known issue, there are some workarounds that can be used in the mean time to provide relief until the fix is released. The user can choose one of these (they are not all required in order to workaround the issue)  - 

  1. Open the invite on the Calendar in Outlook for iOS to respond (user has already confirmed that is a valid workaround)
  2. Choose "My delegates and me" option on the main delegate settings screen
  3. Uncheck "Delegate receives copies of meeting-related messages sent to me" this is found on the Permissions tab for delegate(s)
  4. Change the permission for the delegate(s) under Calendar section to Author or some other (except Editor)  

@jerryngan, my user has confirmed that the "my delegates and me" option brought back the RSVP option.  


A patch is supposedly coming to the mobile app sometime early this week