Using the 'sync' button in SharePoint library does not sync files/folders

Brass Contributor

Hi - I'm not sure if this is an issue with SharePoint or with OneDrive.

We have an issue when trying to sync additional files/folders from a SharePoint library. If we go into our OneDrive settings and choose folders to sync, the folders will generally sync without an issue. However if we try to use the sync button directly from the SharePoint library, a window briefly opens saying 'Getting ready to sync...' and then nothing happens.


It's only seems to be an issue when we're already syncing some of the folders in that same library - it seems we cannot sync additional files or folders using that method...which is a little frustrating!


Is there any solution to this or is it a known issue?


Thank you

11 Replies
Maybe try IE/Edge to see if it helps, but it should work fine. Let me see if I can reproduce.
Worked fine, did a different folder in same library, both times say about to sync, the popped open onedrive and synced.
Yeah, this should work , although ive seen some delay in explorer, showing the synced folders! Refresh or restart explorer / log out / restart and see if they show up then

@adam deltinger @Chris Webb 

Hi Guys - thanks for the replies.

I've tried it again but still no luck. I'm using edge, select the subfolder I'd like to sync, hit the sync button, I get the 'getting ready to sync...' box and then a request to open OneDrive (which I approve), but then a tray notification to say I'm already syncing the root folder.


Perhaps I need to get our IT support to check out configuration??

Hmm! Im sure this happened to me! Trying to think of what I did!
Try this: go to settings in Onedrive and remove the root folder sync there! Then sync the sub folders! Then if you need the entire root folder do that last

@adam deltinger 


Thanks Adam - Seems a bit odd tho that once you've synced the root folder, you can't add subfolders from the browser. I know it works through the onedrive settings function, but seems like such a straightforward function to have available!


I'll keep trying however!

Makes sense to me. Why would you want to sync again when your already syncing the files?

@Chris Webb 

Sorry - I don't think I explained that correctly, or perhaps using the wrong terms.

I meant that I've synced some subfolders from the library already (not the entire library) so I have a link to the main folder within OneDrive and synced sub folders within it. What I've been trying to do within the browser is sync additional folders from that library, and that's the part that's failing. Unless I go into the OneDrive settings and add folders that way.

@Angela McGhin try switching to OneDrive Classic and re-syncing.


@Angela McGhin

I am also facing a similar problem. I recently bought 1TB OneDrive space for personal use. When I try to use "Sync" option, the popup with the message "Getting ready to sync.." appears and it stays without any further execution.


Could you please post any ideas to fix this problem? That would be of really great help.




Best regards,


When i try to edit Onenote since "teams". I can edit, add some text, etc. perfect. 


But, when i want to edit with de App (not web app) and try to sync. 


I always had the problem. "Getting ready to sync..." and not finish the process

I think that there is a problem  between sharepoint online and the Apps with the sync process. Sync process cannot detect which file is the newest and appears the "Getting ready...".

I have try:

Close Office
Close process

Stop-Process -Name "Msosync"

Stop-Process -Name "Msouc"

Stop-Process -Name "Groove"

Stop-Process -Name "OneDrive"

Stop-Process -Name "Teams"


Clear caché:


HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Internet\Server Cache


Add web to Truster Center:
* Inetcpl.cpl -> Trusted sites

* OneNote -> File -> Options -> Trusted sites