OneDrive Error -10001 in MacBook Pro M2 Pro with macOS14.5

Copper Contributor

After install the newest version OneDrive app from Microsoft web.

OneDrive app didn't start correctly, pop up an error code -10001, I cannot even click any button in the icon tool (Top Right corner), so it's not possible to Quit OneDrive or get into the setting page in the App.

I try the following ways, but this issue keep happening when the app was starting up.

 

1. Move the OneDrive application to the trash and download the program again from official OneDrive web (version 24.086.0428.0003)

2. Reboot the MacBook

3. Update the macOS to latest macOS14.5 (2024-06-11)

4. Delete all the file that I can find in Finder App

 

MacBook Pro 14" 2023 M2 Pro, from Taiwan Apple Store

---

I try to found solution in Microsoft Community, however the user that have the same error, cannot fix there problems too!

More than 20 users click "I have the same question" under the error-10001 post. No one has  respond that their problem were solved. I believe this error happens currently for more than one year.螢幕截圖 2024-06-11 23.39.53.png

 

1. FreyaVandenBroeck with MacBook Air MacOS 14.5 (23F79)  on 01 Jun 2024

https://techcommunity.microsoft.com/t5/onedrive/onedrive-on-mac/m-p/4157541

 

2. Benjamin Wang1  with MacBook Pro 2019 Intel i9 MacOS 13.4. on 02 Jul 2023

https://answers.microsoft.com/en-us/msoffice/forum/all/onedrive-files-on-demand-didnt-start-error-co...

 

螢幕截圖 2024-06-11 22.19.51.png螢幕截圖 2024-06-11 22.09.49.png

4 Replies
Having the same issue with same model on 14.4. Extremely weird. Still not solved after these steps. :\

@design620tw 

Hi guys, I had the same issue on an M3 MacBook Pro with Sonoma 14.5, which I was able to solve by reseting OneDrive.
This is different to a reinstall,  or moving the application to trash, which did not fix my issue.

Instructions are here:
https://support.microsoft.com/en-gb/office/reset-onedrive-34701e00-bf7b-42db-b960-84905399050c

Thank you! Unfortunately, this did not solve my issue but I'll test again and if I find any fixes apart from this I'll update this thread :)