Syncing only on PCs joined to specific domains is not working

%3CLINGO-SUB%20id%3D%22lingo-sub-44411%22%20slang%3D%22en-US%22%3ESyncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-44411%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20checked%20the%20box%20in%20the%20new%20OneDrive%20admin%20portal%20to%20allow%20syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20and%20I've%20entered%20the%20GUID%20of%20my%20domain%20but%20I'm%20still%20able%20to%20sync%20from%20my%20personal%20machines.%20%26nbsp%3BIs%20there%20any%20troubleshooting%20I%20can%20do%20or%20should%20I%20open%20a%20ticket%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-44411%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOneDrive%20for%20Business%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESync%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-197601%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-197601%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20I%20know%20this%20was%20a%20while%20ago%20but%20did%20you%20get%20a%20resolution%20to%20this%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-52641%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-52641%22%20slang%3D%22en-US%22%3EThanks.%20I'm%20seeing%20the%20same%20thing%20as%20you%20on%20of%20my%20computers%20but%20the%20others%20are%20behaving%20differently.%20I%20just%20used%20powershell%20to%20Set-SPOTenantSyncClientRestriction%20and%20the%20000s%20still%20show%20when%20I%20run%20Get-SPOTenantSyncClientRestriction%2C%20very%20weird.%20I'm%20going%20to%20open%20a%20support%20ticket%20with%20MS%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-52635%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-52635%22%20slang%3D%22en-US%22%3E%3CP%3EFYI%2C%20it%20appears%20to%20now%20be%20working%20for%20me.%20%26nbsp%3BAt%20least%20I%20can't%20recreate%20the%20issue%20anywhere%20to%20open%20a%20ticket.%20On%20the%20machines%20where%20it%20was%20not%20taking%20effect%20and%20I%20had%20set%20up%20syncing%20I%20now%20get%20a%20message%20box%20that%20says%20OneDrive%20can%20no%20longer%20sync%20my%20folder%20because%20my%20%22IT%20Department%20requires%20that%20you%20use%20a%20computer%20that%20is%20joined%20to%20an%20approved%20domain%20to%20sync%20this%20folder.%22%20%26nbsp%3BThis%20is%20the%20expected%20behavior.%20%26nbsp%3BOn%20a%20laptop%20where%20I%20had%20not%20yet%20set%20up%20syncing%20it%20says%20%22Sorry%2C%20OneDrive%20can't%20add%20your%20folder%20right%20now.%20%26nbsp%3BPlease%20contact%20support%22.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-52622%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-52622%22%20slang%3D%22en-US%22%3E%3CP%3ENo%2C%20I%20only%20see%20the%20GUID%20for%20my%20domain%20that%20I%20added.%20%26nbsp%3BI%20removed%20and%20re-added%20it%20but%20still%20only%20see%20that%20GUID%2C%20no%20GUID%20with%20zeros.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-52610%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-52610%22%20slang%3D%22en-US%22%3E%3CP%3EI%20added%20the%20GUID%20for%20our%20domain%2C%20and%20the%20Sync%26nbsp%3Bscreen%20shows%20a%20second%20GUID%20of%20all%20zeroes%2C%20%26nbsp%3Bi.e%2C%20myguid%2C%2000000000-0000-0000-0000-000000000000.%20I%20just%20removed%20the%20000's%20and%20then%20they%20came%20back.%20Are%20you%20seeing%20the%20same%20thing%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-52601%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-52601%22%20slang%3D%22en-US%22%3E%3CP%3EI%20haven't.%20%26nbsp%3BI%20was%20going%20to%20open%20a%20ticket%20with%20Microsoft%20this%20week.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-52600%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-52600%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F427%22%20target%3D%22_blank%22%3E%40Kevin%20Hoyt%3C%2FA%3E%26nbsp%3BI%20activated%20this%20setting%20and%20I'm%20getting%20inconsistent%20behavior.%20We%20have%20one%20account%20that%20can%20no%20longer%20sync%20when%20not%20on%20the%20network%20and%20others%20that%20can.%20Very%20weird.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHave%20you%20been%20able%20to%20run%20any%20more%20tests%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-48083%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-48083%22%20slang%3D%22en-US%22%3EThe%20way%20I%20read%20it%2C%20is%20that%20uploads%20will%20continue%20forever%2C%20but%20changes%20in%20the%20browser%20won't%20be%20pushed%2Fsynced%20back%20to%20the%20workstation.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-44616%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-44616%22%20slang%3D%22en-US%22%3E%3CP%3ENo%20idea%2C%20the%20way%20I%20read%20it%2C%20it%20should%20(try%20to)%20create%20new%20one%20after%20you%20disconnected%20the%20account.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-44538%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-44538%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20but%20at%20what%20point%20does%20that%20existing%20relationship%20expire%3F%20%26nbsp%3BI%20disconnected%20my%20account%20and%20successfully%20reconnected%20it.%20%26nbsp%3BWill%20it%20never%20block%20it%20on%20that%20machine%20now%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-44487%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-44487%22%20slang%3D%22en-US%22%3E%3CP%3EIf%20you%20had%20an%20existing%20sync%20relationship%20before%20configuring%20the%20setting%2C%20it%20will%20keep%20on%20uploading%20files.%20Also%2C%20it%20doesnt%20affect%20Mac%20users.%20Details%20are%20here%3A%20%3CA%20href%3D%22https%3A%2F%2Ftechnet.microsoft.com%2Fen-us%2Flibrary%2Fdn917455.aspx%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Ftechnet.microsoft.com%2Fen-us%2Flibrary%2Fdn917455.aspx%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-44429%22%20slang%3D%22en-US%22%3ERe%3A%20Syncing%20only%20on%20PCs%20joined%20to%20specific%20domains%20is%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-44429%22%20slang%3D%22en-US%22%3EHow%20long%20did%20you%20wait%20before%20testing%20again%3F%20It%20might%20take%20some%20time%20to%20activate%20and%20lock%20down.%3CBR%20%2F%3EAlso%20are%20the%20machines%20that%20can%20sync%20ones%20that%20already%20were%20previously%2C%20or%20new%3F%3C%2FLINGO-BODY%3E
Frequent Contributor

I've checked the box in the new OneDrive admin portal to allow syncing only on PCs joined to specific domains and I've entered the GUID of my domain but I'm still able to sync from my personal machines.  Is there any troubleshooting I can do or should I open a ticket?

12 Replies
How long did you wait before testing again? It might take some time to activate and lock down.
Also are the machines that can sync ones that already were previously, or new?

If you had an existing sync relationship before configuring the setting, it will keep on uploading files. Also, it doesnt affect Mac users. Details are here: https://technet.microsoft.com/en-us/library/dn917455.aspx

Thanks but at what point does that existing relationship expire?  I disconnected my account and successfully reconnected it.  Will it never block it on that machine now?

No idea, the way I read it, it should (try to) create new one after you disconnected the account.

The way I read it, is that uploads will continue forever, but changes in the browser won't be pushed/synced back to the workstation.

@Kevin Hoyt I activated this setting and I'm getting inconsistent behavior. We have one account that can no longer sync when not on the network and others that can. Very weird.

 

Have you been able to run any more tests?

I haven't.  I was going to open a ticket with Microsoft this week.

I added the GUID for our domain, and the Sync screen shows a second GUID of all zeroes,  i.e, myguid, 00000000-0000-0000-0000-000000000000. I just removed the 000's and then they came back. Are you seeing the same thing?

No, I only see the GUID for my domain that I added.  I removed and re-added it but still only see that GUID, no GUID with zeros.

FYI, it appears to now be working for me.  At least I can't recreate the issue anywhere to open a ticket. On the machines where it was not taking effect and I had set up syncing I now get a message box that says OneDrive can no longer sync my folder because my "IT Department requires that you use a computer that is joined to an approved domain to sync this folder."  This is the expected behavior.  On a laptop where I had not yet set up syncing it says "Sorry, OneDrive can't add your folder right now.  Please contact support".

Thanks. I'm seeing the same thing as you on of my computers but the others are behaving differently. I just used powershell to Set-SPOTenantSyncClientRestriction and the 000s still show when I run Get-SPOTenantSyncClientRestriction, very weird. I'm going to open a support ticket with MS

Hi I know this was a while ago but did you get a resolution to this problem.

 

Thanks