Microsoft Teams Error mailbox does not exist

%3CLINGO-SUB%20id%3D%22lingo-sub-476175%22%20slang%3D%22en-US%22%3EMicrosoft%20Teams%20Error%20mailbox%20does%20not%20exist%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-476175%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20i%20have%20a%20problem%20with%20my%20Echange%202016%20CU12%20Hybrid%20configuration.%20I%20have%20many%20accepted%20domains.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Emy%20on%20prem%20AD%20domain%20is%20%22corp.contoso.com%22%3C%2FP%3E%3CP%3EExchange%20accepted%20domains%20%3A%20%22contoso.com%22%20%2C%20%22fabrikam.com%22%3C%2FP%3E%3CP%3EAD%20usernames%20example%3A%20flastname%40corp.contoso.com%3C%2FP%3E%3CP%3Eon%20prem%20email%20Address%3A%20firtsname.lastname%40fabrikam.com%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20configured%20Office%20365%20Hybrid%20(%20sync%20users%2C%20configure%20exchange%20hybrid%2C%20configure%20federated%20domains(%20contoso.com%2C%20fabrikam.com)%20%2C%20all%20settings%20is%20ok.%20But%20when%20i%20log%20in%20my%20teams(with%20my%20----%22flastname%40corp.contoso.com%22%26nbsp%3B%20credentials)%20on%20calendar%20tab%20i%20have%20an%20error%26nbsp%3B%20mailbox%20does%20not%20exist%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20987px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F109641iAE3E098DF1609FCC%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%221.PNG%22%20title%3D%221.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-476175%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHybrid%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOn-Premises%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-476512%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Teams%20Error%20mailbox%20does%20not%20exist%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-476512%22%20slang%3D%22en-US%22%3ECheck%20the%20O-auth%20setting%2C%20you%20can%20test%20it%20at%20the%20bottom%20of%20this%20article%20and%20if%20not%2C%20get%20it%20configured%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fexchange%2Fconfigure-oauth-authentication-between-exchange-and-exchange-online-organizations-exchange-2013-help%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fexchange%2Fconfigure-oauth-authentication-between-exchange-and-exchange-online-organizations-exchange-2013-help%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EOnly%20thing%20I%20know%20to%20check%20if%20it's%20not%20working.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-476580%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Teams%20Error%20mailbox%20does%20not%20exist%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-476580%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3B%20thank%20you%20for%20your%20reply%2C%20i%20checked%20each%20OAuth%20settings%20(O365%20--on%20prem%20and%20on%20prem%20--O365)%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eokay%2C%20my%20all%20mailoxes%20is%20on%20premise%2C%20i%20checked%20onprem%20--%20office%20365%20%2C%20it%20success%3C%2FP%3E%3CP%3Ebut%20i%20created%20new%20exchange%20online%20mailbox%20then%20test%20office%20365%20--%20on%20prem%20it%20gave%20an%20error%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E--------------------------------------------------------------------------------------------%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F109654i014E4B8CA73E2F3A%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%222.PNG%22%20title%3D%222.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-477437%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Teams%20Error%20mailbox%20does%20not%20exist%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-477437%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3B%20also%20i%20found%20this%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F109697iE1BEE775EB73ACDC%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%221.PNG%22%20title%3D%221.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-477945%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Teams%20Error%20mailbox%20does%20not%20exist%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-477945%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3Bi%20checked%20Oauth%20and%20is%20working%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1060555%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Teams%20Error%20mailbox%20does%20not%20exist%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1060555%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F129056%22%20target%3D%22_blank%22%3E%40Ramil%20Memmedov%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ehave%20the%20same%20Issue.%20Did%20you%20solve%20it%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1310400%22%20slang%3D%22de-DE%22%3ESubject%3A%20Microsoft%20Teams%20Error%20mailbox%20does%20not%20exist%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1310400%22%20slang%3D%22de-DE%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F129056%22%20target%3D%22_blank%22%3E%40Ramil%20Memmedov%3C%2FA%3E%26nbsp%3BI%20have%20the%20same%20problem.%20Have%20anyone%20of%20you%20been%20able%20to%20solve%20it%3F%20I%20am%20grateful%20for%20every%20tip.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi i have a problem with my Echange 2016 CU12 Hybrid configuration. I have many accepted domains.

 

my on prem AD domain is "corp.contoso.com"

Exchange accepted domains : "contoso.com" , "fabrikam.com"

AD usernames example: flastname@corp.contoso.com

on prem email Address: firtsname.lastname@fabrikam.com

 

I configured Office 365 Hybrid ( sync users, configure exchange hybrid, configure federated domains( contoso.com, fabrikam.com) , all settings is ok. But when i log in my teams(with my ----"flastname@corp.contoso.com"  credentials) on calendar tab i have an error  mailbox does not exist1.PNG

5 Replies
Highlighted
Check the O-auth setting, you can test it at the bottom of this article and if not, get it configured: https://docs.microsoft.com/en-us/exchange/configure-oauth-authentication-between-exchange-and-exchan...

Only thing I know to check if it's not working.
Highlighted

@Chris Webb  also i found this1.PNG

Highlighted

@Chris Webb i checked Oauth and is working 

Highlighted

@Ramil Memmedov 

have the same Issue. Did you solve it?

Highlighted

@Ramil Memmedov I have the same problem. Has anyone of you been able to solve it? I am grateful for every tip.