SOLVED

Unable to Log Into Teams on iPhone. Error: Sign-in Error

Occasional Contributor

Hello,

 

Has anyone been able to resolve the Sign-In Error issue? It appears to be an issue between the Microsoft Authenticator app and Teams. Our organization is using Conditional Access policies to require MFA via the Microsoft Authenticator App. After MFA completes and the phone returns to Teams, the error message is displayed. Azure AD Sign-In log displays MFA success.

 

Steps to produce:

 

1. Open Teams
2. add account tscbank.com
3. select work account
4. Flips to Microsoft Authenticator
5. Enter Password
6. Flips to Teams
7. Displays error: Sign-In Error

 

Here is what I've tried:

 

- deleted the account from Teams
- restarted the phone
- reinstalled teams
-  tried to delete cache from Teams settings in iOS General (never seems to clear)
- removed email address from personal Microsoft account

3 Replies

Hello @Anon4343   If this older post from our answers.microsoft.com tech support site doesn't provide a solution, you may want to open your own ticket there: Microsoft teams sign-in-error on Iphone - Microsoft Community

It did not. I'll post there as well. Thank you.
best response confirmed by Anon4343 (Occasional Contributor)
Solution

It looks like the issue was caused by Teams not applying an InTune policy. We're using InTune to manage Teams. For some reason, teams wasn't applying the organization's data management policy and was getting blocked. Teams wasn't showing the user that this app will be managed and needs to be restarted.

 

The resolution was to receive a message in Teams and not view it. Eventually, the user will receive an email stating that a teammate is trying to reach you in Microsoft Teams. Within that email, there is a link to 'Reply in Teams'. If the user opens that link on their mobile device, it correctly initiates data management policy and manages Teams. The user was able to successfully log into Teams.