Teams stuck in "Loading latest updates..." error

Copper Contributor

I have been having the same error with Teams for the past few months, across two different computers, and with me having uninstalled and reinstalled Teams several times.  Effectively, Teams works fine the first time it is reinstalled, but when I go to use it the following day, even if the computer has not been shut down in the meantime, I get a "Loading latest updates... in the meantime, you can still send and respond to messages" line in the toolbar.  I cannot actually send or respond to messages (or receive them) while this is going on, though. 

 

If anyone has any suggestions, I would really appreciate the guidance - Teams is effectively unusable for me right now, which is a problem given how much we use it to communicate in my department.

4 Replies
i've same problem
I am experiencing the same issue. Need help please.
Have the same issue on laptop with teams.
I tried clear the teams cache it helped for a short period of time (few hours and then teams stuck again).
Reinstall do the same effect.
Interesting part sometimes teams send messages but doesn't receiving.
That's absurd.

I suspect this may be the network problem, but I can't allocate it.
But on the same network teams doesn't work on laptop but works just fine on mobile.
Same issue. Desktop Teams app and EDGE give me this issue but teams works fine on Firefox or on iOS devices. Would love someone from the team to address these issues.