Teams not available in default app associations

Copper Contributor

Teams application is not available to select for the TEL url in 'default apps by protocol'. I have Windows 10 devices that are deployed through Autopilot and during the testing, an issue has been identified that when clicking on any telephone numbers on a website, it is being prompted to pick an app. Looking through the app list, Teams is not available. I have checked in default apps section and do not seem to find Teams as an app. All browsers have same issue.


My personal laptop is fine and TEL protocol has default app selected as Teams. Tried below so far and nothing worked.


Deployed Teams through MEM as an msi package and also tried with Microsoft 365 apps

Manually installed Teams as machine wide installer and also on user context

Imported default file association to include Teams for TeamsURL programID


If anyone can share their thoughts or ideas, it would be great.


2 Replies

Good day, 


I have the same problem. See attached screenshot. 


Thank you. image.png

@klracelissmartcon , I see this behaviour too. Teams MSI deployed using SCCM.